# CVE-2012-1053: Puppet Privilege Escallation

> Local attackers can escalate privileges in Puppet due to improper group privilege management in the SUIDManager, allowing unauthorized access to higher permissions.

- **Severity:** Medium 6.9 (`AV:L/AC:M/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2012
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-1053, GHSA-77hg-g8cc-5r37

## What is CVE-2012-1053?

CVE-2012-1053 is a medium-severity vulnerability in Puppet Puppet Enterprise, published on 29 May 2012. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The change_user method in the SUIDManager (lib/puppet/util/suidmanager.rb) in Puppet 2.6.x before 2.6.14 and 2.7.x before 2.7.11, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x before 2.0.3 does not properly manage group privileges, which allows local users to gain privileges via vectors related to (1) the change_user not dropping supplementary groups in certain conditions, (2) changes to the eguid without associated changes to the egid, or (3) the addition of the real gid to supplementary groups.

Weakness: CWE-264

## Which versions are affected by CVE-2012-1053?

4 open source packages ship an affected version, including puppet. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puppet` | RubyGems | From 2.6 | 2.6.14 |
| `puppet` | RubyGems | From 2.6 | 2.6.14 |
| `puppet` | RubyGems | From 2.7 | 2.7.11 |
| `puppet` | RubyGems | From 2.7 | 2.7.11 |

Products: Puppet Puppet, Puppet Puppet Enterprise, Puppetlabs Puppet, Puppetlabs Puppet Enterprise Users.

## How do I fix CVE-2012-1053?

Upgrade puppet to a fixed version for your release line: 2.6.14 or 2.7.11.

## Is CVE-2012-1053 being exploited?

There is no known exploitation of CVE-2012-1053 in the wild and no public exploit code.

## Other vulnerabilities in Puppet Puppet Enterprise

- [CVE-2016-2785](https://insights.sbomify.com/CVE-2016-2785/): Puppet Improper Access Control (critical 9.8)
- [CVE-2021-27021](https://insights.sbomify.com/CVE-2021-27021/): SQL injection in Puppet DB (high 8.8)
- [CVE-2018-6513](https://insights.sbomify.com/CVE-2018-6513/): Privilege escalation in Puppet Enterprise and Puppet Agent (high 8.8)
- [CVE-2018-6514](https://insights.sbomify.com/CVE-2018-6514/): Privilege escalation in Puppet Agent (high 7.8)
- [CVE-2018-6515](https://insights.sbomify.com/CVE-2018-6515/): Code injection in Puppet Agent (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-1053 and fix it if it is affected.

What it is: CVE-2012-1053 is a medium-severity vulnerability in Puppet Puppet Enterprise, published on 29 May 2012. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-1053 in the wild and no public exploit code.

Affected packages and fixed versions:
- puppet (RubyGems): affected from 2.6; fixed in 2.6.14
- puppet (RubyGems): affected from 2.6; fixed in 2.6.14
- puppet (RubyGems): affected from 2.7; fixed in 2.7.11
- puppet (RubyGems): affected from 2.7; fixed in 2.7.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-1053/ (Markdown: https://insights.sbomify.com/CVE-2012-1053/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-1053
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-1053
- OSV: https://osv.dev/vulnerability/CVE-2012-1053

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-1053/
Summaries are generated and may contain mistakes; the official description above is the record.
