CVE-2012-1156 Moodle backs up private files
High 7.5
Published
Updated
Check this codebase for CVE-2012-1156 and fix it if it is affected.
What it is: CVE-2012-1156 is a high-severity vulnerability in Fedoraproject Fedora, published on 14 Nov 2019.
Exploitation: There is no known exploitation of CVE-2012-1156 in the wild and no public exploit code.
Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 2.0; fixed in 2.0.8
- moodle/moodle (Packagist): affected from 2.0; fixed in 2.0.8
- moodle/moodle (Packagist): affected from 2.1; fixed in 2.1.5
- moodle/moodle (Packagist): affected from 2.1; fixed in 2.1.5
- moodle/moodle (Packagist): affected from 2.2; fixed in 2.2.2
- moodle/moodle (Packagist): affected from 2.2; fixed in 2.2.2
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2012-1156/ (Markdown: https://insights.sbomify.com/CVE-2012-1156/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2012-1156?
CVE-2012-1156 is a high-severity vulnerability in Fedoraproject Fedora, published on 14 Nov 2019.
Official description
Moodle before 2.2.2 has users' private files included in course backups
Weakness: CWE-532
Which versions are affected by CVE-2012-1156?
6 open source packages ship an affected version, including moodle/moodle. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.0 | 2.0.8 |
moodle/moodle Packagist | From 2.0 | 2.0.8 |
moodle/moodle Packagist | From 2.1 | 2.1.5 |
moodle/moodle Packagist | From 2.1 | 2.1.5 |
moodle/moodle Packagist | From 2.2 | 2.2.2 |
moodle/moodle Packagist | From 2.2 | 2.2.2 |
Products include Fedoraproject Fedora, Moodle Moodle, Redhat Enterprise Linux.
How do I fix CVE-2012-1156?
Upgrade moodle/moodle to a fixed version for your release line: 2.0.8, 2.1.5 or 2.2.2.
Is CVE-2012-1156 being exploited?
There is no known exploitation of CVE-2012-1156 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as GHSA-358r-g2xw-7c83.