CVE-2012-1157 Moodle default permissions too permissive

Medium 4.3 Published Updated

Moodle allows all users to view all repositories by default, leading to unauthorized information disclosure.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2012-1157?

CVE-2012-1157 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 14 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Moodle before 2.2.2 has a default repository capabilities issue where all repositories are viewable by all users by default

Weakness: CWE-276

Which versions are affected by CVE-2012-1157?

8 open source packages ship an affected version, including moodle/moodle. It affects 2 products.

PackageAffectedFixed in
moodle/moodle PackagistAll versions1.9.17
moodle/moodle PackagistAll versions1.9.17
moodle/moodle PackagistFrom 2.02.0.8
moodle/moodle PackagistFrom 2.02.0.8
moodle/moodle PackagistFrom 2.12.1.5
moodle/moodle PackagistFrom 2.12.1.5
2 more packages
moodle/moodle PackagistFrom 2.22.2.2
moodle/moodle PackagistFrom 2.22.2.2

Products include Fedoraproject Fedora, Moodle Moodle.

How do I fix CVE-2012-1157?

Upgrade moodle/moodle to a fixed version for your release line: 1.9.17, 2.0.8, 2.1.5 or 2.2.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2012-1157 being exploited?

There is no known exploitation of CVE-2012-1157 in the wild and no public exploit code.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as GHSA-2x36-7xfm-pgm7.

Is CVE-2012-1157 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free