# CVE-2012-1159: Moodle included private user files in course backups

> An attacker can view hidden courses in Moodle via the overview report, exposing unauthorized course data to users.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-p9hr-f4xj-8w8r

## What is CVE-2012-1159?

CVE-2012-1159 is a medium-severity vulnerability in Fedoraproject Fedora, published on 14 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Moodle before 2.2.2: Overview report allows users to see hidden courses

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2012-1159?

8 open source packages ship an affected version, including moodle/moodle. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 1.9.17 |
| `moodle/moodle` | Packagist | All versions | 1.9.17 |
| `moodle/moodle` | Packagist | From 2.0 | 2.0.8 |
| `moodle/moodle` | Packagist | From 2.0 | 2.0.8 |
| `moodle/moodle` | Packagist | From 2.1 | 2.1.5 |
| `moodle/moodle` | Packagist | From 2.1 | 2.1.5 |
| `moodle/moodle` | Packagist | From 2.2 | 2.2.2 |
| `moodle/moodle` | Packagist | From 2.2 | 2.2.2 |

Products: Fedoraproject Fedora, Moodle Moodle.

## How do I fix CVE-2012-1159?

Upgrade moodle/moodle to a fixed version for your release line: 1.9.17, 2.0.8, 2.1.5 or 2.2.2.

## Is CVE-2012-1159 being exploited?

There is no known exploitation of CVE-2012-1159 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-1159 and fix it if it is affected.

What it is: CVE-2012-1159 is a medium-severity vulnerability in Fedoraproject Fedora, published on 14 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-1159 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 1.9.17
- moodle/moodle (Packagist): affected all versions; fixed in 1.9.17
- moodle/moodle (Packagist): affected from 2.0; fixed in 2.0.8
- moodle/moodle (Packagist): affected from 2.0; fixed in 2.0.8
- moodle/moodle (Packagist): affected from 2.1; fixed in 2.1.5
- moodle/moodle (Packagist): affected from 2.1; fixed in 2.1.5
- moodle/moodle (Packagist): affected from 2.2; fixed in 2.2.2
- moodle/moodle (Packagist): affected from 2.2; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-1159/ (Markdown: https://insights.sbomify.com/CVE-2012-1159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-1159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-1159
- OSV: https://osv.dev/vulnerability/CVE-2012-1159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-1159/
Summaries are generated and may contain mistakes; the official description above is the record.
