{"answers":{"affected":"3 open source packages ship an affected version, including pyfribidi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-1176 in the wild and no public exploit code.","fix":"Upgrade pyfribidi to 0.11.0 or later.","what":"CVE-2012-1176 is a medium-severity memory corruption vulnerability in n/a, published on 26 Aug 2012. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-1176 and fix it if it is affected.\n\nWhat it is: CVE-2012-1176 is a medium-severity memory corruption vulnerability in n/a, published on 26 Aug 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-1176 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pyfribidi (PyPI): affected all versions; fixed in 0.11.0\n- pyfribidi (PyPI): affected all versions; fixed in 0.11.0\n- pyfribidi (PyPI): affected all versions; fixed in 0.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-1176/ (Markdown: https://insights.sbomify.com/CVE-2012-1176/index.md)","id":"CVE-2012-1176","markdown":"https://insights.sbomify.com/CVE-2012-1176/index.md","name":"CVE-2012-1176","record":{"aliases":["DEBIAN-CVE-2012-1176","GHSA-6476-g47x-h3c7","PYSEC-2012-11"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python Unicode library","requires_auth":"none","summary":"Remote attackers can crash applications using PyFriBidi by sending a malformed 4-byte UTF-8 sequence, causing a buffer overflow.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"pyfribidi","vendor":"fribidi"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"Buffer overflow in the fribidi_utf8_to_unicode function in PyFriBidi before 0.11.0 allows remote attackers to cause a denial of service (application crash) via a 4-byte utf-8 sequence.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PyFriBidi Buffer overflow in the fribidi_utf8_to_unicode function","id":"CVE-2012-1176","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2012"},"n_packages":3,"n_references":13,"next":{"headline":"Weak cryptography in n/a","id":"CVE-2012-1177"},"packages":[{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"pyfribidi","purl":null,"source":"GHSA-6476-g47x-h3c7"},{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"pyfribidi","purl":"pkg:pypi/pyfribidi","source":"GHSA-6476-g47x-h3c7"},{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"pyfribidi","purl":"pkg:pypi/pyfribidi","source":"PYSEC-2012-11"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2012-1175"},"products":["n/a"],"published":"2012-08-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can crash applications using PyFriBidi by sending a malformed 4-byte UTF-8 sequence, causing a buffer overflow.","url":"https://insights.sbomify.com/CVE-2012-1176/"}