CVE-2012-1296 Elefant CMS Multiple XSS Vulnerabilities
Remote attackers can inject arbitrary web script or HTML via title or body parameters in the admin preview handler, requiring admin access to exploit.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2012-1296?
CVE-2012-1296 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Aug 2012. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in apps/admin/handlers/preview.php in Elefant CMS 1.0.x before 1.0.2-Beta and 1.1.x before 1.1.5-Beta allow remote attackers to inject arbitrary web script or HTML via the (1) title or (2) body parameter to admin/preview.
Weakness: CWE-79
Which versions are affected by CVE-2012-1296?
4 open source packages ship an affected version, including elefant/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
elefant/cms Packagist | From 1.0 | 1.0.2-Beta |
elefant/cms Packagist | From 1.0 | 1.0.2-Beta |
elefant/cms Packagist | From 1.1 | 1.1.5-Beta |
elefant/cms Packagist | From 1.1 | 1.1.5-Beta |
Products include Elefantcms Elefantcms.
How do I fix CVE-2012-1296?
Upgrade elefant/cms to a fixed version for your release line: 1.0.2-Beta or 1.1.5-Beta.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2012-1296 being exploited?
There is no known exploitation of CVE-2012-1296 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-qjjq-rcq8-jw6j.