{"answers":{"affected":"4 open source packages ship an affected version, including elefant/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-1296 in the wild and no public exploit code.","fix":"Upgrade elefant/cms to a fixed version for your release line: 1.0.2-Beta or 1.1.5-Beta.","what":"CVE-2012-1296 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Aug 2012. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2012-1296 and fix it if it is affected.\n\nWhat it is: CVE-2012-1296 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Aug 2012. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2012-1296 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- elefant/cms (Packagist): affected from 1.0; fixed in 1.0.2-Beta\n- elefant/cms (Packagist): affected from 1.0; fixed in 1.0.2-Beta\n- elefant/cms (Packagist): affected from 1.1; fixed in 1.1.5-Beta\n- elefant/cms (Packagist): affected from 1.1; fixed in 1.1.5-Beta\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-1296/ (Markdown: https://insights.sbomify.com/CVE-2012-1296/index.md)","id":"CVE-2012-1296","markdown":"https://insights.sbomify.com/CVE-2012-1296/index.md","name":"CVE-2012-1296","record":{"aliases":["GHSA-qjjq-rcq8-jw6j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Elefant CMS","requires_auth":"high_privilege","summary":"Remote attackers can inject arbitrary web script or HTML via title or body parameters in the admin preview handler, requiring admin access to exploit.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"elefantcms","vendor":"elefantcms"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in apps/admin/handlers/preview.php in Elefant CMS 1.0.x before 1.0.2-Beta and 1.1.x before 1.1.5-Beta allow remote attackers to inject arbitrary web script or HTML via the (1) title or (2) body parameter to admin/preview.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Elefant CMS Multiple XSS Vulnerabilities","id":"CVE-2012-1296","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2012"},"n_packages":4,"n_references":6,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2012-1297"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.2-Beta"],"introduced":["1.0"],"last_affected":[],"package":"elefant/cms","purl":null,"source":"GHSA-qjjq-rcq8-jw6j"},{"ecosystem":"Packagist","fixed":["1.0.2-Beta"],"introduced":["1.0"],"last_affected":[],"package":"elefant/cms","purl":"pkg:composer/elefant/cms","source":"GHSA-qjjq-rcq8-jw6j"},{"ecosystem":"Packagist","fixed":["1.1.5-Beta"],"introduced":["1.1"],"last_affected":[],"package":"elefant/cms","purl":null,"source":"GHSA-qjjq-rcq8-jw6j"},{"ecosystem":"Packagist","fixed":["1.1.5-Beta"],"introduced":["1.1"],"last_affected":[],"package":"elefant/cms","purl":"pkg:composer/elefant/cms","source":"GHSA-qjjq-rcq8-jw6j"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2012-1294"},"products":["n/a"],"published":"2012-08-26","related":[{"cvss_score":9.8,"headline":"Elefant CMS Improper Input Validation","id":"CVE-2018-15601","kev_date_added":null,"published":"2018-08-21"},{"cvss_score":8.8,"headline":"Elefant CMS CSRF Vulnerability","id":"CVE-2018-16387","kev_date_added":null,"published":"2018-09-03"},{"cvss_score":4.3,"headline":"Elefant CMS Version Comparison Persistent cross site scriting","id":"CVE-2017-20058","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2012-6521","kev_date_added":null,"published":"2013-01-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via title or body parameters in the admin preview handler, requiring admin access to exploit.","url":"https://insights.sbomify.com/CVE-2012-1296/"}