# CVE-2012-1296: Elefant CMS Multiple XSS Vulnerabilities

> Remote attackers can inject arbitrary web script or HTML via title or body parameters in the admin preview handler, requiring admin access to exploit.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Aug 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-qjjq-rcq8-jw6j

## What is CVE-2012-1296?

CVE-2012-1296 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Aug 2012. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in apps/admin/handlers/preview.php in Elefant CMS 1.0.x before 1.0.2-Beta and 1.1.x before 1.1.5-Beta allow remote attackers to inject arbitrary web script or HTML via the (1) title or (2) body parameter to admin/preview.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2012-1296?

4 open source packages ship an affected version, including elefant/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elefant/cms` | Packagist | From 1.0 | 1.0.2-Beta |
| `elefant/cms` | Packagist | From 1.0 | 1.0.2-Beta |
| `elefant/cms` | Packagist | From 1.1 | 1.1.5-Beta |
| `elefant/cms` | Packagist | From 1.1 | 1.1.5-Beta |

Products: Elefantcms Elefantcms.

## How do I fix CVE-2012-1296?

Upgrade elefant/cms to a fixed version for your release line: 1.0.2-Beta or 1.1.5-Beta.

## Is CVE-2012-1296 being exploited?

There is no known exploitation of CVE-2012-1296 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-15601](https://insights.sbomify.com/CVE-2018-15601/): Elefant CMS Improper Input Validation (critical 9.8)
- [CVE-2018-16387](https://insights.sbomify.com/CVE-2018-16387/): Elefant CMS CSRF Vulnerability (high 8.8)
- [CVE-2017-20058](https://insights.sbomify.com/CVE-2017-20058/): Elefant CMS Version Comparison Persistent cross site scriting (medium 4.3)
- [CVE-2012-6521](https://insights.sbomify.com/CVE-2012-6521/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-1296 and fix it if it is affected.

What it is: CVE-2012-1296 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Aug 2012. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2012-1296 in the wild and no public exploit code.

Affected packages and fixed versions:
- elefant/cms (Packagist): affected from 1.0; fixed in 1.0.2-Beta
- elefant/cms (Packagist): affected from 1.0; fixed in 1.0.2-Beta
- elefant/cms (Packagist): affected from 1.1; fixed in 1.1.5-Beta
- elefant/cms (Packagist): affected from 1.1; fixed in 1.1.5-Beta

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-1296/ (Markdown: https://insights.sbomify.com/CVE-2012-1296/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-1296
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-1296
- OSV: https://osv.dev/vulnerability/CVE-2012-1296

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-1296/
Summaries are generated and may contain mistakes; the official description above is the record.
