# CVE-2012-1500: Cross-site scripting in n/a

> An attacker can inject arbitrary script code via stored XSS in JIRA, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 13 Feb 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-7qc8-6vj6-vfrq

## What is CVE-2012-1500?

CVE-2012-1500 is a medium-severity cross-site scripting vulnerability in Atlassian Jira, published on 13 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Stored XSS vulnerability in UpdateFieldJson.jspa in JIRA 4.4.3 and GreenHopper before 5.9.8 allows an attacker to inject arbitrary script code.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2012-1500?

It affects 2 products.


Products: Atlassian Greenhopper, Atlassian Jira.

## How do I fix CVE-2012-1500?

No fix has been published for CVE-2012-1500 yet. Limit exposure of the affected software until one is available.

## Is CVE-2012-1500 being exploited?

There is no known exploitation of CVE-2012-1500 in the wild and no public exploit code.

Public exploit code:

- jira 4.4.3 / greenhopper < 5.9.8 - Multiple Vulnerabilities (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-1500 and fix it if it is affected.

What it is: CVE-2012-1500 is a medium-severity cross-site scripting vulnerability in Atlassian Jira, published on 13 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2012-1500 in the wild and no public exploit code.

Affected product: Atlassian Jira. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-1500/ (Markdown: https://insights.sbomify.com/CVE-2012-1500/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-1500
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-1500
- OSV: https://osv.dev/vulnerability/CVE-2012-1500

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-1500/
Summaries are generated and may contain mistakes; the official description above is the record.
