CVE-2012-1574 Apache Hadoop allows impersonation of arbitrary cluster user accounts

Medium 6.5 Published Updated

Remote authenticated users can impersonate arbitrary cluster accounts in Apache Hadoop Kerberos/MapReduce, leading to privilege escalation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2012-1574?

CVE-2012-1574 is a medium-severity authentication bypass vulnerability in n/a, published on 12 Apr 2012. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The Kerberos/MapReduce security functionality in Apache Hadoop 0.20.203.0 through 0.20.205.0, 0.23.x before 0.23.2, and 1.0.x before 1.0.2, as used in Cloudera CDH CDH3u0 through CDH3u2, Cloudera hadoop-0.20-sbin before 0.20.2+923.197, and other products, allows remote authenticated users to impersonate arbitrary cluster user accounts via unspecified vectors.

Weakness: CWE-310

Which versions are affected by CVE-2012-1574?

4 open source packages ship an affected version, including org.apache.hadoop:hadoop-main. It affects 3 products.

PackageAffectedFixed in
org.apache.hadoop:hadoop-main MavenFrom 0.230.23.2
org.apache.hadoop:hadoop-main MavenFrom 0.230.23.2
org.apache.hadoop:hadoop-main MavenFrom 1.01.0.2
org.apache.hadoop:hadoop-main MavenFrom 1.01.0.2

Products include Apache Hadoop, Cloudera Cloudera Cdh, Cloudera Hadoop.

How do I fix CVE-2012-1574?

Upgrade org.apache.hadoop:hadoop-main to a fixed version for your release line: 0.23.2 or 1.0.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2012-1574 being exploited?

There is no known exploitation of CVE-2012-1574 in the wild and no public exploit code.

Sources

Also known as GHSA-c6f9-4pmv-m7m6.

Is CVE-2012-1574 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free