# CVE-2012-1574: Apache Hadoop allows impersonation of arbitrary cluster user accounts

> Remote authenticated users can impersonate arbitrary cluster accounts in Apache Hadoop Kerberos/MapReduce, leading to privilege escalation.

- **Severity:** Medium 6.5 (`AV:N/AC:L/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-c6f9-4pmv-m7m6

## What is CVE-2012-1574?

CVE-2012-1574 is a medium-severity authentication bypass vulnerability in n/a, published on 12 Apr 2012. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Kerberos/MapReduce security functionality in Apache Hadoop 0.20.203.0 through 0.20.205.0, 0.23.x before 0.23.2, and 1.0.x before 1.0.2, as used in Cloudera CDH CDH3u0 through CDH3u2, Cloudera hadoop-0.20-sbin before 0.20.2+923.197, and other products, allows remote authenticated users to impersonate arbitrary cluster user accounts via unspecified vectors.

Weakness: CWE-310

## Which versions are affected by CVE-2012-1574?

4 open source packages ship an affected version, including org.apache.hadoop:hadoop-main. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-main` | Maven | From 0.23 | 0.23.2 |
| `org.apache.hadoop:hadoop-main` | Maven | From 0.23 | 0.23.2 |
| `org.apache.hadoop:hadoop-main` | Maven | From 1.0 | 1.0.2 |
| `org.apache.hadoop:hadoop-main` | Maven | From 1.0 | 1.0.2 |

Products: Apache Hadoop, Cloudera Cloudera Cdh, Cloudera Hadoop.

## How do I fix CVE-2012-1574?

Upgrade org.apache.hadoop:hadoop-main to a fixed version for your release line: 0.23.2 or 1.0.2.

## Is CVE-2012-1574 being exploited?

There is no known exploitation of CVE-2012-1574 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-1574 and fix it if it is affected.

What it is: CVE-2012-1574 is a medium-severity authentication bypass vulnerability in n/a, published on 12 Apr 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-1574 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-main (Maven): affected from 0.23; fixed in 0.23.2
- org.apache.hadoop:hadoop-main (Maven): affected from 0.23; fixed in 0.23.2
- org.apache.hadoop:hadoop-main (Maven): affected from 1.0; fixed in 1.0.2
- org.apache.hadoop:hadoop-main (Maven): affected from 1.0; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-1574/ (Markdown: https://insights.sbomify.com/CVE-2012-1574/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-1574
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-1574
- OSV: https://osv.dev/vulnerability/CVE-2012-1574

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-1574/
Summaries are generated and may contain mistakes; the official description above is the record.
