# CVE-2012-1592: Unrestricted Upload of File with Dangerous Type in Apache Struts2

> A local code execution vulnerability in Apache Struts2 allows malicious users to upload and execute arbitrary files via malformed XSLT processing.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-8m5q-crqq-6pmf

## What is CVE-2012-1592?

CVE-2012-1592 is a high-severity vulnerability in Apache Struts, published on 5 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A local code execution issue exists in Apache Struts2 when processing malformed XSLT files, which could let a malicious user upload and execute arbitrary files.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2012-1592?

2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0 | 2.5.22 |
| `org.apache.struts:struts2-core` | Maven | From 2.0 | 2.5.22 |

Products: Apache Struts.

## How do I fix CVE-2012-1592?

Upgrade org.apache.struts:struts2-core to 2.5.22 or later.

## Is CVE-2012-1592 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2012-1592 exists.

Public exploit code:

- Apache Struts 2.0 - 'XSLTResult.java' Arbitrary File Upload (exploitdb)

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-1592 and fix it if it is affected.

What it is: CVE-2012-1592 is a high-severity vulnerability in Apache Struts, published on 5 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2012-1592 exists.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0; fixed in 2.5.22
- org.apache.struts:struts2-core (Maven): affected from 2.0; fixed in 2.5.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-1592/ (Markdown: https://insights.sbomify.com/CVE-2012-1592/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-1592
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-1592
- OSV: https://osv.dev/vulnerability/CVE-2012-1592

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-1592/
Summaries are generated and may contain mistakes; the official description above is the record.
