# CVE-2012-1605: Typo3 Extbase Framework Unsafe Deserialization

> Remote attackers can execute arbitrary code by sending untrusted serialized data to the TYPO3 Extbase Framework due to missing HMAC validation.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2012
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-7jfm-px59-99w8

## What is CVE-2012-1605?

CVE-2012-1605 is a medium-severity unsafe deserialization vulnerability in Typo3 Typo3, published on 4 Sep 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Extbase Framework in TYPO3 4.6.x through 4.6.6, 4.7, and 6.0 unserializes untrusted data, which allows remote attackers to unserialize arbitrary objects and possibly execute arbitrary code via vectors related to "a missing signature (HMAC) for a request argument."

## Which versions are affected by CVE-2012-1605?

6 open source packages ship an affected version, including typo3/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | From 4.4.0 | 4.4.14 |
| `typo3/cms` | Packagist | From 4.4.0 | 4.4.14 |
| `typo3/cms` | Packagist | From 4.5.0 | 4.5.14 |
| `typo3/cms` | Packagist | From 4.5.0 | 4.5.14 |
| `typo3/cms` | Packagist | From 4.6 | 4.6.7 |
| `typo3/cms` | Packagist | From 4.6 | 4.6.7 |

Products: Typo3 Typo3.

## How do I fix CVE-2012-1605?

Upgrade typo3/cms to a fixed version for your release line: 4.4.14, 4.5.14 or 4.6.7.

## Is CVE-2012-1605 being exploited?

There is no known exploitation of CVE-2012-1605 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-1605 and fix it if it is affected.

What it is: CVE-2012-1605 is a medium-severity unsafe deserialization vulnerability in Typo3 Typo3, published on 4 Sep 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-1605 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected from 4.4.0; fixed in 4.4.14
- typo3/cms (Packagist): affected from 4.4.0; fixed in 4.4.14
- typo3/cms (Packagist): affected from 4.5.0; fixed in 4.5.14
- typo3/cms (Packagist): affected from 4.5.0; fixed in 4.5.14
- typo3/cms (Packagist): affected from 4.6; fixed in 4.6.7
- typo3/cms (Packagist): affected from 4.6; fixed in 4.6.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-1605/ (Markdown: https://insights.sbomify.com/CVE-2012-1605/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-1605
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-1605
- OSV: https://osv.dev/vulnerability/CVE-2012-1605

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-1605/
Summaries are generated and may contain mistakes; the official description above is the record.
