CVE-2012-1606 Typo3 Backend XSS Vulnerabilities

Low 3.5 Published Updated

Authenticated backend users can inject arbitrary scripts into TYPO3, potentially leading to session hijacking or data theft.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2012-1606?

CVE-2012-1606 is a low-severity cross-site scripting vulnerability in Typo3 Typo3, published on 4 Sep 2012. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Multiple cross-site scripting (XSS) vulnerabilities in the Backend component in TYPO3 4.4.0 through 4.4.13, 4.5.0 through 4.5.13, 4.6.0 through 4.6.6, 4.7, and 6.0 allow remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79

Which versions are affected by CVE-2012-1606?

6 open source packages ship an affected version, including typo3/cms. It affects 1 product.

PackageAffectedFixed in
typo3/cms PackagistFrom 4.4.04.4.14
typo3/cms PackagistFrom 4.4.04.4.14
typo3/cms PackagistFrom 4.5.04.5.14
typo3/cms PackagistFrom 4.5.04.5.14
typo3/cms PackagistFrom 4.6.04.6.7
typo3/cms PackagistFrom 4.6.04.6.7

Products include Typo3 Typo3.

How do I fix CVE-2012-1606?

Upgrade typo3/cms to a fixed version for your release line: 4.4.14, 4.5.14 or 4.6.7.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2012-1606 being exploited?

There is no known exploitation of CVE-2012-1606 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-7wwr-p84q-qr3q.

Is CVE-2012-1606 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free