CVE-2012-1608 Typo3 API XSS Vulnerabilities

Medium 5.0 Published Updated

Remote attackers can bypass XSS protection in TYPO3 to inject arbitrary scripts using non-printable characters, requiring user interaction to execute.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2012-1608?

CVE-2012-1608 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 4 Sep 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The t3lib_div::RemoveXSS API method in TYPO3 4.4.0 through 4.4.13, 4.5.0 through 4.5.13, 4.6.0 through 4.6.6, 4.7, and 6.0 allows remote attackers to bypass the cross-site scripting (XSS) protection mechanism and inject arbitrary web script or HTML via non printable characters.

Weakness: CWE-20

Which versions are affected by CVE-2012-1608?

6 open source packages ship an affected version, including typo3/cms. It affects 1 product.

PackageAffectedFixed in
typo3/cms PackagistFrom 4.4.04.4.14
typo3/cms PackagistFrom 4.4.04.4.14
typo3/cms PackagistFrom 4.5.04.5.14
typo3/cms PackagistFrom 4.5.04.5.14
typo3/cms PackagistFrom 4.6.04.6.7
typo3/cms PackagistFrom 4.6.04.6.7

Products include Typo3 Typo3.

How do I fix CVE-2012-1608?

Upgrade typo3/cms to a fixed version for your release line: 4.4.14, 4.5.14 or 4.6.7.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2012-1608 being exploited?

There is no known exploitation of CVE-2012-1608 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-w3v6-r62r-fvqh.

Is CVE-2012-1608 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free