{"answers":{"affected":"2 open source packages ship an affected version, including org.postgresql:postgresql. It affects 2 products.","exploited":"There is no known exploitation of CVE-2012-1618 in the wild and no public exploit code.","fix":"Upgrade org.postgresql:postgresql to 8.2 or later.","what":"CVE-2012-1618 is a high-severity SQL injection vulnerability in Postgresql Postgresql, published on 6 Oct 2012. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-1618 and fix it if it is affected.\n\nWhat it is: CVE-2012-1618 is a high-severity SQL injection vulnerability in Postgresql Postgresql, published on 6 Oct 2012. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-1618 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.postgresql:postgresql (Maven): affected all versions; fixed in 8.2\n- org.postgresql:postgresql (Maven): affected all versions; fixed in 8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-1618/ (Markdown: https://insights.sbomify.com/CVE-2012-1618/index.md)","id":"CVE-2012-1618","markdown":"https://insights.sbomify.com/CVE-2012-1618/index.md","name":"CVE-2012-1618","record":{"aliases":["GHSA-h86w-m5rm-xr33"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"PostgreSQL JDBC driver","requires_auth":"low_privilege","summary":"Remote attackers can perform SQL injection via improper parameter escaping in the PostgreSQL JDBC driver when standard_conforming_strings is enabled.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"postgresql","vendor":"postgresql"},{"product":"postgresql_jdbc_driver","vendor":"postgresql"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"Interaction error in the PostgreSQL JDBC driver before 8.2, when used with a PostgreSQL server with the \"standard_conforming_strings\" option enabled, such as the default configuration of PostgreSQL 9.1, does not properly escape unspecified JDBC statement parameters, which allows remote attackers to perform SQL injection attacks.  NOTE: as of 20120330, it was claimed that the upstream developer planned to dispute this issue, but an official dispute has not been posted as of 20121005.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unescaped parameters in the PostgreSQL JDBC driver","id":"CVE-2012-1618","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"postgresql:postgresql","products":["postgresql:postgresql"],"type":"sql_injection","year":"2012"},"n_packages":2,"n_references":12,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2012-1619"},"packages":[{"ecosystem":"Maven","fixed":["8.2"],"introduced":["0"],"last_affected":[],"package":"org.postgresql:postgresql","purl":null,"source":"GHSA-h86w-m5rm-xr33"},{"ecosystem":"Maven","fixed":["8.2"],"introduced":["0"],"last_affected":[],"package":"org.postgresql:postgresql","purl":"pkg:maven/org.postgresql/postgresql","source":"GHSA-h86w-m5rm-xr33"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2012-1617"},"products":["n/a"],"published":"2012-10-06","related":[{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1902","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1903","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2007-3279","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2002-1399","kev_date_added":null,"published":"2003-01-08"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2016-3065","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2007-3280","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":8.8,"headline":"PostgreSQL tsvector and tsquery undersize allocations, via integer wraparound","id":"CVE-2026-14662","kev_date_added":null,"published":"2026-08-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can perform SQL injection via improper parameter escaping in the PostgreSQL JDBC driver when standard_conforming_strings is enabled.","url":"https://insights.sbomify.com/CVE-2012-1618/"}