# CVE-2012-1618: Unescaped parameters in the PostgreSQL JDBC driver

> Remote attackers can perform SQL injection via improper parameter escaping in the PostgreSQL JDBC driver when standard_conforming_strings is enabled.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-h86w-m5rm-xr33

## What is CVE-2012-1618?

CVE-2012-1618 is a high-severity SQL injection vulnerability in Postgresql Postgresql, published on 6 Oct 2012. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Interaction error in the PostgreSQL JDBC driver before 8.2, when used with a PostgreSQL server with the "standard_conforming_strings" option enabled, such as the default configuration of PostgreSQL 9.1, does not properly escape unspecified JDBC statement parameters, which allows remote attackers to perform SQL injection attacks.  NOTE: as of 20120330, it was claimed that the upstream developer planned to dispute this issue, but an official dispute has not been posted as of 20121005.

## Which versions are affected by CVE-2012-1618?

2 open source packages ship an affected version, including org.postgresql:postgresql. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.postgresql:postgresql` | Maven | All versions | 8.2 |
| `org.postgresql:postgresql` | Maven | All versions | 8.2 |

Products: Postgresql Postgresql, Postgresql Postgresql Jdbc Driver.

## How do I fix CVE-2012-1618?

Upgrade org.postgresql:postgresql to 8.2 or later.

## Is CVE-2012-1618 being exploited?

There is no known exploitation of CVE-2012-1618 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-1618 and fix it if it is affected.

What it is: CVE-2012-1618 is a high-severity SQL injection vulnerability in Postgresql Postgresql, published on 6 Oct 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-1618 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.postgresql:postgresql (Maven): affected all versions; fixed in 8.2
- org.postgresql:postgresql (Maven): affected all versions; fixed in 8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-1618/ (Markdown: https://insights.sbomify.com/CVE-2012-1618/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-1618
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-1618
- OSV: https://osv.dev/vulnerability/CVE-2012-1618

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-1618/
Summaries are generated and may contain mistakes; the official description above is the record.
