# CVE-2012-1826: dotCMS allows remote authenticated users to execute arbitrary Java code

> Authenticated attackers can execute arbitrary Java code via crafted XSLT or Velocity templates in dotCMS, requiring an upgrade to secure the system.

- **Severity:** Medium 6.0 (`AV:N/AC:M/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-42vg-q6mw-cfh5

## What is CVE-2012-1826?

CVE-2012-1826 is a medium-severity code injection vulnerability in Dotcms Dotcms, published on 8 Jun 2012. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

dotCMS 1.9 before 1.9.5.1 allows remote authenticated users to execute arbitrary Java code via a crafted (1) XSLT or (2) Velocity template.

Weakness: CWE-264

## Which versions are affected by CVE-2012-1826?

2 open source packages ship an affected version, including com.dotcms:dotcms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.dotcms:dotcms` | Maven | From 1.9 | 1.9.5.1 |
| `com.dotcms:dotcms` | Maven | From 1.9 | 1.9.5.1 |

Products: Dotcms Dotcms.

## How do I fix CVE-2012-1826?

Upgrade com.dotcms:dotcms to 1.9.5.1 or later.

## Is CVE-2012-1826 being exploited?

There is no known exploitation of CVE-2012-1826 in the wild and no public exploit code.

## Other vulnerabilities in Dotcms Dotcms

- [CVE-2022-26352](https://insights.sbomify.com/CVE-2022-26352/): dotCMS Unrestricted Upload of File (critical 9.8, exploited in the wild)
- [CVE-2020-19138](https://insights.sbomify.com/CVE-2020-19138/): File upload in n/a (critical 9.8)
- [CVE-2020-6754](https://insights.sbomify.com/CVE-2020-6754/): Path traversal in n/a (critical 9.8)
- [CVE-2017-5344](https://insights.sbomify.com/CVE-2017-5344/): SQL injection in n/a (critical 9.8)
- [CVE-2016-2355](https://insights.sbomify.com/CVE-2016-2355/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-1826 and fix it if it is affected.

What it is: CVE-2012-1826 is a medium-severity code injection vulnerability in Dotcms Dotcms, published on 8 Jun 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-1826 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.dotcms:dotcms (Maven): affected from 1.9; fixed in 1.9.5.1
- com.dotcms:dotcms (Maven): affected from 1.9; fixed in 1.9.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-1826/ (Markdown: https://insights.sbomify.com/CVE-2012-1826/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-1826
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-1826
- OSV: https://osv.dev/vulnerability/CVE-2012-1826

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-1826/
Summaries are generated and may contain mistakes; the official description above is the record.
