# CVE-2012-1906: Puppet uses predictable filenames, allowing arbitrary file overwrite

> Local attackers can overwrite arbitrary files or install malicious packages via symlink attacks on predictable temporary files during Mac OS X package installation.

- **Severity:** Low 3.3 (`AV:L/AC:M/Au:N/C:N/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2012
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-1906, GHSA-c4mc-49hq-q275

## What is CVE-2012-1906?

CVE-2012-1906 is a low-severity path traversal vulnerability in Puppet Puppet Enterprise, published on 29 May 2012. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 uses predictable file names when installing Mac OS X packages from a remote source, which allows local users to overwrite arbitrary files or install arbitrary packages via a symlink attack on a temporary file in /tmp.

Weakness: CWE-264

## Which versions are affected by CVE-2012-1906?

4 open source packages ship an affected version, including puppet. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puppet` | RubyGems | From 2.6 | 2.6.15 |
| `puppet` | RubyGems | From 2.6 | 2.6.15 |
| `puppet` | RubyGems | From 2.7 | 2.7.13 |
| `puppet` | RubyGems | From 2.7 | 2.7.13 |

Products: Puppet Puppet, Puppet Puppet Enterprise, Puppetlabs Puppet, Puppetlabs Puppet Enterprise Users.

## How do I fix CVE-2012-1906?

Upgrade puppet to a fixed version for your release line: 2.6.15 or 2.7.13.

## Is CVE-2012-1906 being exploited?

There is no known exploitation of CVE-2012-1906 in the wild and no public exploit code.

## Other vulnerabilities in Puppet Puppet Enterprise

- [CVE-2016-2785](https://insights.sbomify.com/CVE-2016-2785/): Puppet Improper Access Control (critical 9.8)
- [CVE-2021-27021](https://insights.sbomify.com/CVE-2021-27021/): SQL injection in Puppet DB (high 8.8)
- [CVE-2018-6513](https://insights.sbomify.com/CVE-2018-6513/): Privilege escalation in Puppet Enterprise and Puppet Agent (high 8.8)
- [CVE-2018-6514](https://insights.sbomify.com/CVE-2018-6514/): Privilege escalation in Puppet Agent (high 7.8)
- [CVE-2018-6515](https://insights.sbomify.com/CVE-2018-6515/): Code injection in Puppet Agent (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-1906 and fix it if it is affected.

What it is: CVE-2012-1906 is a low-severity path traversal vulnerability in Puppet Puppet Enterprise, published on 29 May 2012. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-1906 in the wild and no public exploit code.

Affected packages and fixed versions:
- puppet (RubyGems): affected from 2.6; fixed in 2.6.15
- puppet (RubyGems): affected from 2.6; fixed in 2.6.15
- puppet (RubyGems): affected from 2.7; fixed in 2.7.13
- puppet (RubyGems): affected from 2.7; fixed in 2.7.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-1906/ (Markdown: https://insights.sbomify.com/CVE-2012-1906/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-1906
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-1906
- OSV: https://osv.dev/vulnerability/CVE-2012-1906

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-1906/
Summaries are generated and may contain mistakes; the official description above is the record.
