CVE-2012-1987 Puppet Denial of Service and Arbitrary File Write
Authenticated attackers can cause denial of service via memory or filesystem exhaustion using crafted REST requests in Puppet.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-1987?
CVE-2012-1987 is a low-severity denial of service vulnerability in Puppet Puppet Enterprise, published on 29 May 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Unspecified vulnerability in Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys to (1) cause a denial of service (memory consumption) via a REST request to a stream that triggers a thread block, as demonstrated using CVE-2012-1986 and /dev/random; or (2) cause a denial of service (filesystem consumption) via crafted REST requests that use "a marshaled form of a Puppet::FileBucket::File object" to write to arbitrary file locations.
Which versions are affected by CVE-2012-1987?
4 open source packages ship an affected version, including puppet. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
puppet RubyGems | From 2.6.0 | 2.6.15 |
puppet RubyGems | From 2.6.0 | 2.6.15 |
puppet RubyGems | From 2.7.0 | 2.7.13 |
puppet RubyGems | From 2.7.0 | 2.7.13 |
Products include Puppet Puppet, Puppet Puppet Enterprise.
How do I fix CVE-2012-1987?
Upgrade puppet to a fixed version for your release line: 2.6.15 or 2.7.13.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2012-1987 being exploited?
There is no known exploitation of CVE-2012-1987 in the wild and no public exploit code.
Other vulnerabilities in Puppet Puppet Enterprise
Sources
Also known as DEBIAN-CVE-2012-1987, GHSA-v58w-6xc2-w799.