{"answers":{"affected":"4 open source packages ship an affected version, including puppet. It affects 2 products.","exploited":"There is no known exploitation of CVE-2012-1987 in the wild and no public exploit code.","fix":"Upgrade puppet to a fixed version for your release line: 2.6.15 or 2.7.13.","what":"CVE-2012-1987 is a low-severity denial of service vulnerability in Puppet Puppet Enterprise, published on 29 May 2012. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-1987 and fix it if it is affected.\n\nWhat it is: CVE-2012-1987 is a low-severity denial of service vulnerability in Puppet Puppet Enterprise, published on 29 May 2012. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-1987 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puppet (RubyGems): affected from 2.6.0; fixed in 2.6.15\n- puppet (RubyGems): affected from 2.6.0; fixed in 2.6.15\n- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.13\n- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-1987/ (Markdown: https://insights.sbomify.com/CVE-2012-1987/index.md)","id":"CVE-2012-1987","markdown":"https://insights.sbomify.com/CVE-2012-1987/index.md","name":"CVE-2012-1987","record":{"aliases":["DEBIAN-CVE-2012-1987","GHSA-v58w-6xc2-w799"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Puppet configuration management","requires_auth":"low_privilege","summary":"Authenticated attackers can cause denial of service via memory or filesystem exhaustion using crafted REST requests in Puppet.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"puppet","vendor":"puppet"},{"product":"puppet_enterprise","vendor":"puppet"}],"cvss":{"score":3.5,"severity":"low","source":"nvd","vector":"AV:N/AC:M/Au:S/C:N/I:N/A:P","version":"2.0"},"cwes":[],"description":"Unspecified vulnerability in Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys to (1) cause a denial of service (memory consumption) via a REST request to a stream that triggers a thread block, as demonstrated using CVE-2012-1986 and /dev/random; or (2) cause a denial of service (filesystem consumption) via crafted REST requests that use \"a marshaled form of a Puppet::FileBucket::File object\" to write to arbitrary file locations.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Puppet Denial of Service and Arbitrary File Write","id":"CVE-2012-1987","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"puppet:puppet_enterprise","products":["puppet:puppet_enterprise"],"type":"denial_of_service","year":"2012"},"n_packages":4,"n_references":19,"next":{"headline":"Puppet Arbitrary Command Execution","id":"CVE-2012-1988"},"packages":[{"ecosystem":"RubyGems","fixed":["2.6.15"],"introduced":["2.6.0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-v58w-6xc2-w799"},{"ecosystem":"RubyGems","fixed":["2.6.15"],"introduced":["2.6.0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-v58w-6xc2-w799"},{"ecosystem":"RubyGems","fixed":["2.7.13"],"introduced":["2.7.0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-v58w-6xc2-w799"},{"ecosystem":"RubyGems","fixed":["2.7.13"],"introduced":["2.7.0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-v58w-6xc2-w799"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2012-1986"},"products":["n/a"],"published":"2012-05-29","related":[{"cvss_score":9.8,"headline":"Puppet Improper Access Control","id":"CVE-2016-2785","kev_date_added":null,"published":"2016-06-10"},{"cvss_score":8.8,"headline":"SQL injection in Puppet DB","id":"CVE-2021-27021","kev_date_added":null,"published":"2021-07-20"},{"cvss_score":8.8,"headline":"Privilege escalation in Puppet Enterprise and Puppet Agent","id":"CVE-2018-6513","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Privilege escalation in Puppet Agent","id":"CVE-2018-6514","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Code injection in Puppet Agent","id":"CVE-2018-6515","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.5,"headline":"Puppet Improper Input Validation vulnerability","id":"CVE-2013-1655","kev_date_added":null,"published":"2013-03-20"},{"cvss_score":6.9,"headline":"Puppet Privilege Escallation","id":"CVE-2012-1053","kev_date_added":null,"published":"2012-05-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated attackers can cause denial of service via memory or filesystem exhaustion using crafted REST requests in Puppet.","url":"https://insights.sbomify.com/CVE-2012-1987/"}