CVE-2012-1988 Puppet Arbitrary Command Execution
Authenticated users with file permissions can execute arbitrary commands on the Puppet master via shell metacharacters in file paths.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-1988?
CVE-2012-1988 is a medium-severity command injection vulnerability in Canonical Ubuntu Linux, published on 29 May 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys and file-creation permissions on the puppet master to execute arbitrary commands by creating a file whose full pathname contains shell metacharacters, then performing a filebucket request.
Weakness: CWE-78
Which versions are affected by CVE-2012-1988?
4 open source packages ship an affected version, including puppet. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
puppet RubyGems | From 2.6.0 | 2.6.15 |
puppet RubyGems | From 2.6.0 | 2.6.15 |
puppet RubyGems | From 2.7.0 | 2.7.13 |
puppet RubyGems | From 2.7.0 | 2.7.13 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Puppet Puppet, Puppet Puppet Enterprise.
How do I fix CVE-2012-1988?
Upgrade puppet to a fixed version for your release line: 2.6.15 or 2.7.13.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2012-1988 being exploited?
There is no known exploitation of CVE-2012-1988 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2012-1988, GHSA-6xxq-j39w-g3f6.