# CVE-2012-20001: PrestaShop XSS Vulnerability

> Attackers can inject malicious scripts via the message field in PrestaShop, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Dec 2021
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-j33m-2537-86jm

## What is CVE-2012-20001?

CVE-2012-20001 is a medium-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 21 Dec 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PrestaShop before 1.5.2 allows XSS via the "<object data='data:text/html" substring in the message field.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2012-20001?

2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | All versions | 1.5.2.0 |
| `prestashop/prestashop` | Packagist | All versions | 1.5.2.0 |

Products: Prestashop Prestashop.

## How do I fix CVE-2012-20001?

Upgrade prestashop/prestashop to 1.5.2.0 or later.

## Is CVE-2012-20001 being exploited?

There is no known exploitation of CVE-2012-20001 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-20001 and fix it if it is affected.

What it is: CVE-2012-20001 is a medium-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 21 Dec 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2012-20001 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected all versions; fixed in 1.5.2.0
- prestashop/prestashop (Packagist): affected all versions; fixed in 1.5.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-20001/ (Markdown: https://insights.sbomify.com/CVE-2012-20001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-20001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-20001
- OSV: https://osv.dev/vulnerability/CVE-2012-20001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-20001/
Summaries are generated and may contain mistakes; the official description above is the record.
