{"answers":{"affected":"2 open source packages ship an affected version, including rubygems-update. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-2126 in the wild and no public exploit code.","fix":"Upgrade rubygems-update to 1.8.23 or later.","what":"CVE-2012-2126 is a medium-severity vulnerability in n/a, published on 1 Oct 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2012-2126 and fix it if it is affected.\n\nWhat it is: CVE-2012-2126 is a medium-severity vulnerability in n/a, published on 1 Oct 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2012-2126 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rubygems-update (RubyGems): affected all versions; fixed in 1.8.23\n- rubygems-update (RubyGems): affected all versions; fixed in 1.8.23\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-2126/ (Markdown: https://insights.sbomify.com/CVE-2012-2126/index.md)","id":"CVE-2012-2126","markdown":"https://insights.sbomify.com/CVE-2012-2126/index.md","name":"CVE-2012-2126","record":{"aliases":["DEBIAN-CVE-2012-2126","GHSA-5mgj-mvv8-46mw","UBUNTU-CVE-2012-2126"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby package manager","requires_auth":"none","summary":"RubyGems fails to verify SSL certificates, allowing attackers to inject malicious code into gems during installation via man-in-the-middle attacks.","user_interaction":"required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"rubygems","vendor":"rubygems"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-310","name":null}],"description":"RubyGems before 1.8.23 does not verify an SSL certificate, which allows remote attackers to modify a gem during installation via a man-in-the-middle attack.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RubyGems does not verify SSL certificate","id":"CVE-2012-2126","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"weak_cryptography","year":"2012"},"n_packages":2,"n_references":8,"next":{"headline":"Denial of service in n/a","id":"CVE-2012-2127"},"packages":[{"ecosystem":"RubyGems","fixed":["1.8.23"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-5mgj-mvv8-46mw"},{"ecosystem":"RubyGems","fixed":["1.8.23"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-5mgj-mvv8-46mw"}],"prev":{"headline":"RubyGems HTTPS to HTTP redirect","id":"CVE-2012-2125"},"products":["n/a"],"published":"2013-10-01","related":[{"cvss_score":8.3,"headline":"RubyGems allows creation of users with arbitrary unverified emails","id":"CVE-2022-36073","kev_date_added":null,"published":"2022-09-07"},{"cvss_score":7.8,"headline":"RubyGems Deserialization of Untrusted Data vulnerability","id":"CVE-2018-1000074","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":7.5,"headline":"RubyGems Link Following vulnerability","id":"CVE-2018-1000073","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":7.4,"headline":"RubyGems Delete directory using symlink when decompressing tar","id":"CVE-2019-8320","kev_date_added":null,"published":"2019-06-06"},{"cvss_score":5.8,"headline":"RubyGems HTTPS to HTTP redirect","id":"CVE-2012-2125","kev_date_added":null,"published":"2013-10-01"},{"cvss_score":5.5,"headline":"RubyGems Path Traversal vulnerability","id":"CVE-2018-1000079","kev_date_added":null,"published":"2018-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"RubyGems fails to verify SSL certificates, allowing attackers to inject malicious code into gems during installation via man-in-the-middle attacks.","url":"https://insights.sbomify.com/CVE-2012-2126/"}