# CVE-2012-2126: RubyGems does not verify SSL certificate

> RubyGems fails to verify SSL certificates, allowing attackers to inject malicious code into gems during installation via man-in-the-middle attacks.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Oct 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-2126, GHSA-5mgj-mvv8-46mw, UBUNTU-CVE-2012-2126

## What is CVE-2012-2126?

CVE-2012-2126 is a medium-severity vulnerability in n/a, published on 1 Oct 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

RubyGems before 1.8.23 does not verify an SSL certificate, which allows remote attackers to modify a gem during installation via a man-in-the-middle attack.

Weakness: CWE-310

## Which versions are affected by CVE-2012-2126?

2 open source packages ship an affected version, including rubygems-update. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rubygems-update` | RubyGems | All versions | 1.8.23 |
| `rubygems-update` | RubyGems | All versions | 1.8.23 |

Products: Rubygems Rubygems.

## How do I fix CVE-2012-2126?

Upgrade rubygems-update to 1.8.23 or later.

## Is CVE-2012-2126 being exploited?

There is no known exploitation of CVE-2012-2126 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-36073](https://insights.sbomify.com/CVE-2022-36073/): RubyGems allows creation of users with arbitrary unverified emails (high 8.3)
- [CVE-2018-1000074](https://insights.sbomify.com/CVE-2018-1000074/): RubyGems Deserialization of Untrusted Data vulnerability (high 7.8)
- [CVE-2018-1000073](https://insights.sbomify.com/CVE-2018-1000073/): RubyGems Link Following vulnerability (high 7.5)
- [CVE-2019-8320](https://insights.sbomify.com/CVE-2019-8320/): RubyGems Delete directory using symlink when decompressing tar (high 7.4)
- [CVE-2012-2125](https://insights.sbomify.com/CVE-2012-2125/): RubyGems HTTPS to HTTP redirect (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-2126 and fix it if it is affected.

What it is: CVE-2012-2126 is a medium-severity vulnerability in n/a, published on 1 Oct 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2012-2126 in the wild and no public exploit code.

Affected packages and fixed versions:
- rubygems-update (RubyGems): affected all versions; fixed in 1.8.23
- rubygems-update (RubyGems): affected all versions; fixed in 1.8.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-2126/ (Markdown: https://insights.sbomify.com/CVE-2012-2126/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-2126
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-2126
- OSV: https://osv.dev/vulnerability/CVE-2012-2126

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-2126/
Summaries are generated and may contain mistakes; the official description above is the record.
