# CVE-2012-2140: Mail Gem Improper Input Validation vulnerability

> Remote attackers can execute arbitrary commands via shell metacharacters in sendmail or exim delivery methods within the Ruby Mail gem.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2012
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-2140, GHSA-rp63-jfmw-532w

## What is CVE-2012-2140?

CVE-2012-2140 is a high-severity command injection vulnerability in n/a, published on 18 Jul 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Mail gem before 2.4.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a (1) sendmail or (2) exim delivery.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2012-2140?

2 open source packages ship an affected version, including mail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mail` | RubyGems | All versions | 2.4.3 |
| `mail` | RubyGems | All versions | 2.4.3 |

Products: Rubygems Mail Gem.

## How do I fix CVE-2012-2140?

Upgrade mail to 2.4.3 or later.

## Is CVE-2012-2140 being exploited?

There is no known exploitation of CVE-2012-2140 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2012-2139](https://insights.sbomify.com/CVE-2012-2139/): Mail Gem Path Traversal vulnerability (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-2140 and fix it if it is affected.

What it is: CVE-2012-2140 is a high-severity command injection vulnerability in n/a, published on 18 Jul 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-2140 in the wild and no public exploit code.

Affected packages and fixed versions:
- mail (RubyGems): affected all versions; fixed in 2.4.3
- mail (RubyGems): affected all versions; fixed in 2.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-2140/ (Markdown: https://insights.sbomify.com/CVE-2012-2140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-2140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-2140
- OSV: https://osv.dev/vulnerability/CVE-2012-2140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-2140/
Summaries are generated and may contain mistakes; the official description above is the record.
