CVE-2012-2353 Moodle Exposes Sensitive User Information
Authenticated teachers can view sensitive user information from hidden fields in the enrolled users list.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2012-2353?
CVE-2012-2353 is a medium-severity vulnerability in Moodle Moodle, published on 21 Jul 2012. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to obtain sensitive user information from hidden fields by leveraging the teacher role and navigating to "Enrolled users" under the Users Settings section.
Weakness: CWE-200
Which versions are affected by CVE-2012-2353?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.1 | 2.1.6 |
moodle/moodle Packagist | From 2.1 | 2.1.6 |
moodle/moodle Packagist | From 2.2 | 2.2.3 |
moodle/moodle Packagist | From 2.2 | 2.2.3 |
Products include Moodle Moodle.
How do I fix CVE-2012-2353?
Upgrade moodle/moodle to a fixed version for your release line: 2.1.6 or 2.2.3.
Is CVE-2012-2353 being exploited?
There is no known exploitation of CVE-2012-2353 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-mr97-gvvg-rhgh.