CVE-2012-2356 Moodle Authentication Bypass in Question-Bank
Authenticated users can bypass capability checks to save questions in Moodle, allowing unauthorized data modification.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-2356?
CVE-2012-2356 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 21 Jul 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended capability requirements and save questions via a save_question action.
Weakness: CWE-264
Which versions are affected by CVE-2012-2356?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.1 | 2.1.6 |
moodle/moodle Packagist | From 2.1 | 2.1.6 |
moodle/moodle Packagist | From 2.2 | 2.2.3 |
moodle/moodle Packagist | From 2.2 | 2.2.3 |
Products include Moodle Moodle.
How do I fix CVE-2012-2356?
Upgrade moodle/moodle to a fixed version for your release line: 2.1.6 or 2.2.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2012-2356 being exploited?
There is no known exploitation of CVE-2012-2356 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-3rqj-jchw-9cc7.