{"answers":{"affected":"3 open source packages ship an affected version, including cobbler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-2395 in the wild and no public exploit code.","fix":"Upgrade cobbler to 2.6.0 or later.","what":"CVE-2012-2395 is a high-severity command injection vulnerability in n/a, published on 16 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-2395 and fix it if it is affected.\n\nWhat it is: CVE-2012-2395 is a high-severity command injection vulnerability in n/a, published on 16 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-2395 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cobbler (PyPI): affected all versions; fixed in 2.6.0\n- cobbler (PyPI): affected all versions; fixed in 2.6.0\n- cobbler (PyPI): affected all versions; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-2395/ (Markdown: https://insights.sbomify.com/CVE-2012-2395/index.md)","id":"CVE-2012-2395","markdown":"https://insights.sbomify.com/CVE-2012-2395/index.md","name":"CVE-2012-2395","record":{"aliases":["GHSA-g34c-mg6m-xvxj","PYSEC-2026-792","RHSA-2012:1060"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Cobbler provisioning server","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands via shell metacharacters in username or password fields of the Cobbler xmlrpc API.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"cobbler","vendor":"michael_dehaan"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"Incomplete blacklist vulnerability in action_power.py in Cobbler 2.2.0 allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) username or (2) password fields to the power_system method in the xmlrpc API.","ecosystems":["PyPI","Red Hat:network_satellite:5.4::el5","Red Hat:network_satellite:5.4::el6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cobbler subject to Command Injection","id":"CVE-2012-2395","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2012"},"n_packages":5,"n_references":9,"next":{"headline":"Denial of service in n/a","id":"CVE-2012-2396"},"packages":[{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":null,"source":"GHSA-g34c-mg6m-xvxj"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-g34c-mg6m-xvxj"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"PYSEC-2026-792"},{"ecosystem":"Red Hat:network_satellite:5.4::el5","fixed":["0:2.0.7-14.6.el5sat"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/redhat/cobbler","source":"RHSA-2012:1060"},{"ecosystem":"Red Hat:network_satellite:5.4::el6","fixed":["0:2.0.7-14.6.el6sat"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/redhat/cobbler","source":"RHSA-2012:1060"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2012-2394"},"products":["n/a"],"published":"2012-06-16","related":[{"cvss_score":9,"headline":"Cobbler Web Interface Kickstart Template Remote Privilege Escalation Vulnerability","id":"CVE-2008-6954","kev_date_added":null,"published":"2009-08-12"},{"cvss_score":8.5,"headline":"Cobbler is vulnerable to code injection","id":"CVE-2010-2235","kev_date_added":null,"published":"2010-12-09"},{"cvss_score":7.5,"headline":"Hardcoded credentials in n/a","id":"CVE-2009-5021","kev_date_added":null,"published":"2010-12-09"},{"cvss_score":7.2,"headline":"Misconfiguration in n/a","id":"CVE-2010-4512","kev_date_added":null,"published":"2010-12-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands via shell metacharacters in username or password fields of the Cobbler xmlrpc API.","url":"https://insights.sbomify.com/CVE-2012-2395/"}