{"answers":{"affected":"3 open source packages ship an affected version, including pycrypto and PyCrypto. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-2417 in the wild and no public exploit code.","fix":"Upgrade pycrypto to 2.6 or later.","what":"CVE-2012-2417 is a medium-severity vulnerability in n/a, published on 17 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-2417 and fix it if it is affected.\n\nWhat it is: CVE-2012-2417 is a medium-severity vulnerability in n/a, published on 17 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-2417 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pycrypto (PyPI): affected all versions; fixed in 2.6\n- pycrypto (PyPI): affected all versions; fixed in 2.6\n- PyCrypto (PyPI): affected all versions; fixed in 2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-2417/ (Markdown: https://insights.sbomify.com/CVE-2012-2417/index.md)","id":"CVE-2012-2417","markdown":"https://insights.sbomify.com/CVE-2012-2417/index.md","name":"CVE-2012-2417","record":{"aliases":["DSA-2502-1","GHSA-v367-p58w-98h5","PYSEC-2012-16"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python cryptography library","requires_auth":"none","summary":"Weak prime generation in PyCrypto ElGamal keys allows attackers to brute force private keys and decrypt data.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pycrypto","vendor":"dlitz"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-310","name":null}],"description":"PyCrypto before 2.6 does not produce appropriate prime numbers when using an ElGamal scheme to generate a key, which reduces the signature space or public key space and makes it easier for attackers to conduct brute force attacks to obtain the private key.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PyCrypto makes Use of Insufficiently Random Values","id":"CVE-2012-2417","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2012"},"n_packages":3,"n_references":14,"next":{"headline":"Memory corruption in n/a","id":"CVE-2012-2418"},"packages":[{"ecosystem":"PyPI","fixed":["2.6"],"introduced":["0"],"last_affected":[],"package":"PyCrypto","purl":null,"source":"GHSA-v367-p58w-98h5"},{"ecosystem":"PyPI","fixed":["2.6"],"introduced":["0"],"last_affected":[],"package":"pycrypto","purl":"pkg:pypi/pycrypto","source":"GHSA-v367-p58w-98h5"},{"ecosystem":"PyPI","fixed":["2.6"],"introduced":["0"],"last_affected":[],"package":"pycrypto","purl":"pkg:pypi/pycrypto","source":"PYSEC-2012-16"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2012-2416"},"products":["n/a"],"published":"2012-06-17","related":[{"cvss_score":9.8,"headline":"Buffer Overflow in pycrypto","id":"CVE-2013-7459","kev_date_added":null,"published":"2017-02-15"},{"cvss_score":4.3,"headline":"PyCrypto does not properly reseed PRNG before allowing access","id":"CVE-2013-1445","kev_date_added":null,"published":"2013-10-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Weak prime generation in PyCrypto ElGamal keys allows attackers to brute force private keys and decrypt data.","url":"https://insights.sbomify.com/CVE-2012-2417/"}