# CVE-2012-2417: PyCrypto makes Use of Insufficiently Random Values

> Weak prime generation in PyCrypto ElGamal keys allows attackers to brute force private keys and decrypt data.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2012
- **Updated:** 6 Aug 2024
- **Also known as:** DSA-2502-1, GHSA-v367-p58w-98h5, PYSEC-2012-16

## What is CVE-2012-2417?

CVE-2012-2417 is a medium-severity vulnerability in n/a, published on 17 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PyCrypto before 2.6 does not produce appropriate prime numbers when using an ElGamal scheme to generate a key, which reduces the signature space or public key space and makes it easier for attackers to conduct brute force attacks to obtain the private key.

Weakness: CWE-310

## Which versions are affected by CVE-2012-2417?

3 open source packages ship an affected version, including pycrypto and PyCrypto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pycrypto` | PyPI | All versions | 2.6 |
| `pycrypto` | PyPI | All versions | 2.6 |
| `PyCrypto` | PyPI | All versions | 2.6 |

Products: Dlitz Pycrypto.

## How do I fix CVE-2012-2417?

Upgrade pycrypto to 2.6 or later.

## Is CVE-2012-2417 being exploited?

There is no known exploitation of CVE-2012-2417 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-7459](https://insights.sbomify.com/CVE-2013-7459/): Buffer Overflow in pycrypto (critical 9.8)
- [CVE-2013-1445](https://insights.sbomify.com/CVE-2013-1445/): PyCrypto does not properly reseed PRNG before allowing access (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-2417 and fix it if it is affected.

What it is: CVE-2012-2417 is a medium-severity vulnerability in n/a, published on 17 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-2417 in the wild and no public exploit code.

Affected packages and fixed versions:
- pycrypto (PyPI): affected all versions; fixed in 2.6
- pycrypto (PyPI): affected all versions; fixed in 2.6
- PyCrypto (PyPI): affected all versions; fixed in 2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-2417/ (Markdown: https://insights.sbomify.com/CVE-2012-2417/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-2417
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-2417
- OSV: https://osv.dev/vulnerability/CVE-2012-2417

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-2417/
Summaries are generated and may contain mistakes; the official description above is the record.
