# CVE-2012-2660: Action Pack contains database-query restrictions bypass

> Remote attackers can bypass database query restrictions and NULL checks in Ruby on Rails via crafted requests, potentially accessing restricted data.

- **Severity:** Medium 6.4 (`AV:N/AC:L/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-hgpp-pp89-4fgf

## What is CVE-2012-2660?

CVE-2012-2660 is a medium-severity authentication bypass vulnerability in Rubyonrails Rails, published on 22 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

actionpack/lib/action_dispatch/http/request.rb in Ruby on Rails before 3.0.13, 3.1.x before 3.1.5, and 3.2.x before 3.2.4 does not properly consider differences in parameter handling between the Active Record component and the Rack interface, which allows remote attackers to bypass intended database-query restrictions and perform NULL checks via a crafted request, as demonstrated by certain "[nil]" values, a related issue to CVE-2012-2694.

Weakness: CWE-264

## Which versions are affected by CVE-2012-2660?

8 open source packages ship an affected version, including actionpack. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | All versions | 2.3.16 |
| `actionpack` | RubyGems | All versions | 2.3.16 |
| `actionpack` | RubyGems | From 3.0.0.beta | 3.0.13 |
| `actionpack` | RubyGems | From 3.0.0.beta | 3.0.13 |
| `actionpack` | RubyGems | From 3.1.0 | 3.1.5 |
| `actionpack` | RubyGems | From 3.1.0 | 3.1.5 |
| `actionpack` | RubyGems | From 3.2.0 | 3.2.4 |
| `actionpack` | RubyGems | From 3.2.0 | 3.2.4 |

Products: Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2012-2660?

Upgrade actionpack to a fixed version for your release line: 2.3.16, 3.0.13, 3.1.5 or 3.2.4.

## Is CVE-2012-2660 being exploited?

There is no known exploitation of CVE-2012-2660 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-2660 and fix it if it is affected.

What it is: CVE-2012-2660 is a medium-severity authentication bypass vulnerability in Rubyonrails Rails, published on 22 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-2660 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected all versions; fixed in 2.3.16
- actionpack (RubyGems): affected all versions; fixed in 2.3.16
- actionpack (RubyGems): affected from 3.0.0.beta; fixed in 3.0.13
- actionpack (RubyGems): affected from 3.0.0.beta; fixed in 3.0.13
- actionpack (RubyGems): affected from 3.1.0; fixed in 3.1.5
- actionpack (RubyGems): affected from 3.1.0; fixed in 3.1.5
- actionpack (RubyGems): affected from 3.2.0; fixed in 3.2.4
- actionpack (RubyGems): affected from 3.2.0; fixed in 3.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-2660/ (Markdown: https://insights.sbomify.com/CVE-2012-2660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-2660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-2660
- OSV: https://osv.dev/vulnerability/CVE-2012-2660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-2660/
Summaries are generated and may contain mistakes; the official description above is the record.
