# CVE-2012-2671: Rack-Cache caches sensitive headers

> Attackers can access cached sensitive headers to steal cookies and hijack web sessions in applications using the Rack::Cache library.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2012
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-2671, GHSA-hrp6-w4v2-8737

## What is CVE-2012-2671?

CVE-2012-2671 is a high-severity vulnerability in n/a, published on 17 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Rack::Cache rubygem 0.3.0 through 1.1 caches Set-Cookie and other sensitive headers, which allows attackers to obtain sensitive cookie information, hijack web sessions, or have other unspecified impact by accessing the cache.

## Which versions are affected by CVE-2012-2671?

2 open source packages ship an affected version, including rack-cache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack-cache` | RubyGems | From 0.3.0 | 1.2 |
| `rack-cache` | RubyGems | From 0.3.0 | 1.2 |

Products: Rtomayko Rack-Cach.

## How do I fix CVE-2012-2671?

Upgrade rack-cache to 1.2 or later.

## Is CVE-2012-2671 being exploited?

There is no known exploitation of CVE-2012-2671 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-2671 and fix it if it is affected.

What it is: CVE-2012-2671 is a high-severity vulnerability in n/a, published on 17 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-2671 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack-cache (RubyGems): affected from 0.3.0; fixed in 1.2
- rack-cache (RubyGems): affected from 0.3.0; fixed in 1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-2671/ (Markdown: https://insights.sbomify.com/CVE-2012-2671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-2671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-2671
- OSV: https://osv.dev/vulnerability/CVE-2012-2671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-2671/
Summaries are generated and may contain mistakes; the official description above is the record.
