CVE-2012-2695 activerecord vulnerable to SQL Injection

High 7.5 Published Updated

Remote attackers can execute SQL injection attacks via nested query parameters in Ruby on Rails Active Record, potentially accessing or modifying database contents.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2012-2695?

CVE-2012-2695 is a high-severity SQL injection vulnerability in Rubyonrails Rails, published on 22 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Active Record component in Ruby on Rails before 3.0.14, 3.1.x before 3.1.6, and 3.2.x before 3.2.6 does not properly implement the passing of request data to a where method in an ActiveRecord class, which allows remote attackers to conduct certain SQL injection attacks via nested query parameters that leverage improper handling of nested hashes, a related issue to CVE-2012-2661.

Weakness: CWE-89

Which versions are affected by CVE-2012-2695?

8 open source packages ship an affected version, including activerecord. It affects 2 products.

PackageAffectedFixed in
activerecord RubyGemsAll versions2.3.15
activerecord RubyGemsAll versions2.3.15
activerecord RubyGemsFrom 3.0.0.beta3.0.14
activerecord RubyGemsFrom 3.0.0.beta3.0.14
activerecord RubyGemsFrom 3.1.03.1.6
activerecord RubyGemsFrom 3.1.03.1.6
2 more packages
activerecord RubyGemsFrom 3.2.03.2.6
activerecord RubyGemsFrom 3.2.03.2.6

Products include Rubyonrails Rails, Rubyonrails Ruby on Rails.

How do I fix CVE-2012-2695?

Upgrade activerecord to a fixed version for your release line: 2.3.15, 3.0.14, 3.1.6 or 3.2.6.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2012-2695 being exploited?

There is no known exploitation of CVE-2012-2695 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as GHSA-76wq-xw4h-f8wj.

Is CVE-2012-2695 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free