{"answers":{"affected":"3 open source packages ship an affected version, including feedparser. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-2921 in the wild and no public exploit code.","fix":"Upgrade feedparser to 5.1.2 or later.","what":"CVE-2012-2921 is a medium-severity denial of service vulnerability in n/a, published on 21 May 2012. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-2921 and fix it if it is affected.\n\nWhat it is: CVE-2012-2921 is a medium-severity denial of service vulnerability in n/a, published on 21 May 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-2921 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- feedparser (PyPI): affected all versions; fixed in 5.1.2\n- feedparser (PyPI): affected all versions; fixed in 5.1.2\n- feedparser (PyPI): affected all versions; fixed in 5.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-2921/ (Markdown: https://insights.sbomify.com/CVE-2012-2921/index.md)","id":"CVE-2012-2921","markdown":"https://insights.sbomify.com/CVE-2012-2921/index.md","name":"CVE-2012-2921","record":{"aliases":["DEBIAN-CVE-2012-2921","GHSA-hjf3-r7gw-9rwg","PYSEC-2012-14"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python feed parser","requires_auth":"none","summary":"Remote attackers can cause denial of service via memory consumption using crafted XML entities in non-ASCII documents.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"feedparser","vendor":"mark_pilgrim"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"Universal Feed Parser (aka feedparser or python-feedparser) before 5.1.2 allows remote attackers to cause a denial of service (memory consumption) via a crafted XML ENTITY declaration in a non-ASCII encoded document.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"feedparser denial of service vulnerability","id":"CVE-2012-2921","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2012"},"n_packages":3,"n_references":8,"next":{"headline":"Information disclosure in n/a","id":"CVE-2012-2922"},"packages":[{"ecosystem":"PyPI","fixed":["5.1.2"],"introduced":["0"],"last_affected":[],"package":"feedparser","purl":null,"source":"GHSA-hjf3-r7gw-9rwg"},{"ecosystem":"PyPI","fixed":["5.1.2"],"introduced":["0"],"last_affected":[],"package":"feedparser","purl":"pkg:pypi/feedparser","source":"GHSA-hjf3-r7gw-9rwg"},{"ecosystem":"PyPI","fixed":["5.1.2"],"introduced":["0"],"last_affected":[],"package":"feedparser","purl":"pkg:pypi/feedparser","source":"PYSEC-2012-14"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2012-2920"},"products":["n/a"],"published":"2012-05-21","related":[{"cvss_score":5,"headline":"feedparser denial of service vulnerability","id":"CVE-2011-1156","kev_date_added":null,"published":"2011-04-11"},{"cvss_score":4.3,"headline":"feedparser Cross-site Scripting vulnerability","id":"CVE-2009-5065","kev_date_added":null,"published":"2011-04-11"},{"cvss_score":4.3,"headline":"feedparser Cross-site Scripting vulnerability","id":"CVE-2011-1157","kev_date_added":null,"published":"2011-04-11"},{"cvss_score":4.3,"headline":"feedparser Cross-site Scripting vulnerability","id":"CVE-2011-1158","kev_date_added":null,"published":"2011-04-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via memory consumption using crafted XML entities in non-ASCII documents.","url":"https://insights.sbomify.com/CVE-2012-2921/"}