# CVE-2012-2921: feedparser denial of service vulnerability

> Remote attackers can cause denial of service via memory consumption using crafted XML entities in non-ASCII documents.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2012
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-2921, GHSA-hjf3-r7gw-9rwg, PYSEC-2012-14

## What is CVE-2012-2921?

CVE-2012-2921 is a medium-severity denial of service vulnerability in n/a, published on 21 May 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Universal Feed Parser (aka feedparser or python-feedparser) before 5.1.2 allows remote attackers to cause a denial of service (memory consumption) via a crafted XML ENTITY declaration in a non-ASCII encoded document.

Weakness: CWE-399

## Which versions are affected by CVE-2012-2921?

3 open source packages ship an affected version, including feedparser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `feedparser` | PyPI | All versions | 5.1.2 |
| `feedparser` | PyPI | All versions | 5.1.2 |
| `feedparser` | PyPI | All versions | 5.1.2 |

Products: Mark Pilgrim Feedparser.

## How do I fix CVE-2012-2921?

Upgrade feedparser to 5.1.2 or later.

## Is CVE-2012-2921 being exploited?

There is no known exploitation of CVE-2012-2921 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2011-1156](https://insights.sbomify.com/CVE-2011-1156/): feedparser denial of service vulnerability (medium 5.0)
- [CVE-2009-5065](https://insights.sbomify.com/CVE-2009-5065/): feedparser Cross-site Scripting vulnerability (medium 4.3)
- [CVE-2011-1157](https://insights.sbomify.com/CVE-2011-1157/): feedparser Cross-site Scripting vulnerability (medium 4.3)
- [CVE-2011-1158](https://insights.sbomify.com/CVE-2011-1158/): feedparser Cross-site Scripting vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-2921 and fix it if it is affected.

What it is: CVE-2012-2921 is a medium-severity denial of service vulnerability in n/a, published on 21 May 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-2921 in the wild and no public exploit code.

Affected packages and fixed versions:
- feedparser (PyPI): affected all versions; fixed in 5.1.2
- feedparser (PyPI): affected all versions; fixed in 5.1.2
- feedparser (PyPI): affected all versions; fixed in 5.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-2921/ (Markdown: https://insights.sbomify.com/CVE-2012-2921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-2921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-2921
- OSV: https://osv.dev/vulnerability/CVE-2012-2921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-2921/
Summaries are generated and may contain mistakes; the official description above is the record.
