{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-2944 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2012-2944 is a high-severity memory corruption vulnerability in n/a, published on 1 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-2944 and fix it if it is affected.\n\nWhat it is: CVE-2012-2944 is a high-severity memory corruption vulnerability in n/a, published on 1 Jun 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-2944 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-2944/ (Markdown: https://insights.sbomify.com/CVE-2012-2944/index.md)","id":"CVE-2012-2944","markdown":"https://insights.sbomify.com/CVE-2012-2944/index.md","name":"CVE-2012-2944","record":{"aliases":["DEBIAN-CVE-2012-2944","DSA-2484-1","GHSA-4c72-hpc9-gqmj","openSUSE-SU-2024:10009-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"UPS monitoring server","requires_auth":"none","summary":"Remote attackers can execute arbitrary code or cause denial of service in Network UPS Tools via a buffer overflow in the upsd daemon.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"nut","vendor":"networkupstools"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"Buffer overflow in the addchar function in common/parseconf.c in upsd in Network UPS Tools (NUT) before 2.6.4 allows remote attackers to execute arbitrary code or cause a denial of service (electric-power outage) via a long string containing non-printable characters.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2012-2944","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2012"},"n_packages":1,"n_references":11,"next":{"headline":"Hadoop symlink vulnerability","id":"CVE-2012-2945"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.7.3-2.7"],"introduced":["0"],"last_affected":[],"package":"nut","purl":"pkg:rpm/opensuse/nut\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10009-1"}],"prev":{"headline":"Other in n/a","id":"CVE-2012-2943"},"products":["n/a"],"published":"2012-06-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code or cause denial of service in Network UPS Tools via a buffer overflow in the upsd daemon.","url":"https://insights.sbomify.com/CVE-2012-2944/"}