# CVE-2012-2945: Hadoop symlink vulnerability

> An attacker can exploit symlink handling in Hadoop to read or modify arbitrary files on the server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-v5c9-98f7-2h54

## What is CVE-2012-2945?

CVE-2012-2945 is a high-severity path traversal vulnerability in n/a, published on 28 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hadoop 1.0.3 contains a symlink vulnerability.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2012-2945?

2 open source packages ship an affected version, including org.apache.hadoop:hadoop-main. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-main` | Maven | All versions | 1.0.4 |
| `org.apache.hadoop:hadoop-main` | Maven | All versions | 1.0.4 |

Products: Apache Hadoop.

## How do I fix CVE-2012-2945?

Upgrade org.apache.hadoop:hadoop-main to 1.0.4 or later.

## Is CVE-2012-2945 being exploited?

There is no known exploitation of CVE-2012-2945 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-2945 and fix it if it is affected.

What it is: CVE-2012-2945 is a high-severity path traversal vulnerability in n/a, published on 28 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-2945 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-main (Maven): affected all versions; fixed in 1.0.4
- org.apache.hadoop:hadoop-main (Maven): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-2945/ (Markdown: https://insights.sbomify.com/CVE-2012-2945/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-2945
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-2945
- OSV: https://osv.dev/vulnerability/CVE-2012-2945

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-2945/
Summaries are generated and may contain mistakes; the official description above is the record.
