# CVE-2012-2967: Caucho Quercus, as distributed in Resin, does not properly implement the `==` operator for comparisons

> Caucho Quercus improperly implements the equality operator, leading to unspecified security impacts in applications using this Java-based PHP engine.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Not stated
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 12 Aug 2012
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-2qr7-8fp8-4xxr

## What is CVE-2012-2967?

CVE-2012-2967 is a high-severity vulnerability in n/a, published on 12 Aug 2012. 

### Official description

Caucho Quercus, as distributed in Resin before 4.0.29, does not properly implement the == (equals sign equals sign) operator for comparisons, which has unspecified impact and context-dependent attack vectors.

## Which versions are affected by CVE-2012-2967?

2 open source packages ship an affected version, including com.caucho:resin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.caucho:resin` | Maven | All versions | 4.0.29 |
| `com.caucho:resin` | Maven | All versions | 4.0.29 |

Products: Caucho Resin.

## How do I fix CVE-2012-2967?

Upgrade com.caucho:resin to 4.0.29 or later.

## Is CVE-2012-2967 being exploited?

There is no known exploitation of CVE-2012-2967 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-44138](https://insights.sbomify.com/CVE-2021-44138/): Path Traversal in Caucho Resin (high 7.5)
- [CVE-2012-2965](https://insights.sbomify.com/CVE-2012-2965/): Caucho Quercus, as distributed in Resin, does not properly handle unspecified characters in the names of variables (high 7.5)
- [CVE-2012-2966](https://insights.sbomify.com/CVE-2012-2966/): Caucho Quercus, as distributed in Resin, overwrites entries in SERVER superglobal array on basis of POST parameters (high 7.5)
- [CVE-2012-2969](https://insights.sbomify.com/CVE-2012-2969/): Path traversal in n/a (medium 6.4)
- [CVE-2014-2966](https://insights.sbomify.com/CVE-2014-2966/): Security feature bypass in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-2967 and fix it if it is affected.

What it is: CVE-2012-2967 is a high-severity vulnerability in n/a, published on 12 Aug 2012. 
Exploitation: There is no known exploitation of CVE-2012-2967 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.caucho:resin (Maven): affected all versions; fixed in 4.0.29
- com.caucho:resin (Maven): affected all versions; fixed in 4.0.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-2967/ (Markdown: https://insights.sbomify.com/CVE-2012-2967/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-2967
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-2967
- OSV: https://osv.dev/vulnerability/CVE-2012-2967

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-2967/
Summaries are generated and may contain mistakes; the official description above is the record.
