# CVE-2012-3353: Apache Sling JCR ContentLoader XmlReader Arbitrary File Load

> An attacker can import arbitrary local files into the content repository, leading to potential information disclosure.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-wjp3-4xcq-598p

## What is CVE-2012-3353?

CVE-2012-3353 is a high-severity path traversal vulnerability in Apache Sling, published on 8 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Apache Sling JCR ContentLoader 2.1.4 XmlReader used in the Sling JCR content loader module makes it possible to import arbitrary files in the content repository, including local files, causing potential information leaks. Users should upgrade to version 2.1.6 of the JCR ContentLoader

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2012-3353?

2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.jcr.contentloader. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.sling:org.apache.sling.jcr.contentloader` | Maven | All versions | 2.1.6 |
| `org.apache.sling:org.apache.sling.jcr.contentloader` | Maven | All versions | 2.1.6 |

Products: Apache Sling Jcr Contentloader.

## How do I fix CVE-2012-3353?

Upgrade org.apache.sling:org.apache.sling.jcr.contentloader to 2.1.6 or later.

## Is CVE-2012-3353 being exploited?

There is no known exploitation of CVE-2012-3353 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-3353 and fix it if it is affected.

What it is: CVE-2012-3353 is a high-severity path traversal vulnerability in Apache Sling, published on 8 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-3353 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.sling:org.apache.sling.jcr.contentloader (Maven): affected all versions; fixed in 2.1.6
- org.apache.sling:org.apache.sling.jcr.contentloader (Maven): affected all versions; fixed in 2.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-3353/ (Markdown: https://insights.sbomify.com/CVE-2012-3353/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-3353
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-3353
- OSV: https://osv.dev/vulnerability/CVE-2012-3353

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-3353/
Summaries are generated and may contain mistakes; the official description above is the record.
