# CVE-2012-3361: OpenStack Nova Arbitrary file injection/corruption through directory traversal issues

> Authenticated users can overwrite arbitrary files via symlink attacks in OpenStack Compute, potentially compromising system integrity.

- **Severity:** Medium 5.5 (`AV:N/AC:L/Au:S/C:N/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jul 2012
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-3361, GHSA-cm54-3vvf-f5p8

## What is CVE-2012-3361?

CVE-2012-3361 is a medium-severity path traversal vulnerability in n/a, published on 22 Jul 2012. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

virt/disk/api.py in OpenStack Compute (Nova) Folsom (2012.2), Essex (2012.1), and Diablo (2011.3) allows remote authenticated users to overwrite arbitrary files via a symlink attack on a file in an image.

Weakness: CWE-264

## Which versions are affected by CVE-2012-3361?

2 open source packages ship an affected version, including nova. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nova` | PyPI | All versions | 12.0.0a0 |
| `nova` | PyPI | All versions | 12.0.0a0 |

Products: Openstack Diablo, Openstack Essex, Openstack Folsom.

## How do I fix CVE-2012-3361?

Upgrade nova to 12.0.0a0 or later.

## Is CVE-2012-3361 being exploited?

There is no known exploitation of CVE-2012-3361 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-3361 and fix it if it is affected.

What it is: CVE-2012-3361 is a medium-severity path traversal vulnerability in n/a, published on 22 Jul 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-3361 in the wild and no public exploit code.

Affected packages and fixed versions:
- nova (PyPI): affected all versions; fixed in 12.0.0a0
- nova (PyPI): affected all versions; fixed in 12.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-3361/ (Markdown: https://insights.sbomify.com/CVE-2012-3361/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-3361
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-3361
- OSV: https://osv.dev/vulnerability/CVE-2012-3361

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-3361/
Summaries are generated and may contain mistakes; the official description above is the record.
