{"answers":{"affected":"2 open source packages ship an affected version, including puppet. It affects 2 products.","exploited":"There is no known exploitation of CVE-2012-3408 in the wild and no public exploit code.","fix":"Upgrade puppet to 2.7.18 or later.","what":"CVE-2012-3408 is a low-severity authentication bypass vulnerability in Puppet Puppet Enterprise, published on 6 Aug 2012. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-3408 and fix it if it is affected.\n\nWhat it is: CVE-2012-3408 is a low-severity authentication bypass vulnerability in Puppet Puppet Enterprise, published on 6 Aug 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-3408 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puppet (RubyGems): affected all versions; fixed in 2.7.18\n- puppet (RubyGems): affected all versions; fixed in 2.7.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-3408/ (Markdown: https://insights.sbomify.com/CVE-2012-3408/index.md)","id":"CVE-2012-3408","markdown":"https://insights.sbomify.com/CVE-2012-3408/index.md","name":"CVE-2012-3408","record":{"aliases":["DEBIAN-CVE-2012-3408","GHSA-vxf6-w9mp-95hm"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Puppet configuration management","requires_auth":"none","summary":"Remote attackers can spoof Puppet agents by acquiring previously used IP addresses due to lack of warnings for IP-based certnames.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"puppet_enterprise","vendor":"puppet"},{"product":"puppet","vendor":"puppetlabs"}],"cvss":{"score":2.6,"severity":"low","source":"nvd","vector":"AV:N/AC:H/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"lib/puppet/network/authstore.rb in Puppet before 2.7.18, and Puppet Enterprise before 2.5.2, supports use of IP addresses in certnames without warning of potential risks, which might allow remote attackers to spoof an agent by acquiring a previously used IP address.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Puppet supports use of IP addresses in certnames without warning of potential risks","id":"CVE-2012-3408","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"puppet:puppet_enterprise","products":["puppet:puppet_enterprise"],"type":"auth_bypass","year":"2012"},"n_packages":2,"n_references":3,"next":{"headline":"Privilege escalation in ecryptfs-utils","id":"CVE-2012-3409"},"packages":[{"ecosystem":"RubyGems","fixed":["2.7.18"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-vxf6-w9mp-95hm"},{"ecosystem":"RubyGems","fixed":["2.7.18"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-vxf6-w9mp-95hm"}],"prev":{"headline":"Memory corruption in plow","id":"CVE-2012-3407"},"products":["n/a"],"published":"2012-08-06","related":[{"cvss_score":9.8,"headline":"Privilege escalation in Puppet Enterprise","id":"CVE-2023-2530","kev_date_added":null,"published":"2023-06-07"},{"cvss_score":9.8,"headline":"Hardcoded credentials in Puppet Enterprise","id":"CVE-2019-10694","kev_date_added":null,"published":"2019-12-11"},{"cvss_score":9.8,"headline":"Information disclosure in Puppet Enterprise","id":"CVE-2018-11749","kev_date_added":null,"published":"2018-08-24"},{"cvss_score":8.8,"headline":"Other in Puppet Enterprise","id":"CVE-2021-27020","kev_date_added":null,"published":"2021-08-30"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2015-5686","kev_date_added":null,"published":"2020-02-27"},{"cvss_score":8.8,"headline":"Code injection in Puppet Enterprise","id":"CVE-2016-5716","kev_date_added":null,"published":"2017-08-09"},{"cvss_score":8.8,"headline":"Security feature bypass in n/a","id":"CVE-2015-7330","kev_date_added":null,"published":"2016-04-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can spoof Puppet agents by acquiring previously used IP addresses due to lack of warnings for IP-based certnames.","url":"https://insights.sbomify.com/CVE-2012-3408/"}