# CVE-2012-3408: Puppet supports use of IP addresses in certnames without warning of potential risks

> Remote attackers can spoof Puppet agents by acquiring previously used IP addresses due to lack of warnings for IP-based certnames.

- **Severity:** Low 2.6 (`AV:N/AC:H/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2012
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-3408, GHSA-vxf6-w9mp-95hm

## What is CVE-2012-3408?

CVE-2012-3408 is a low-severity authentication bypass vulnerability in Puppet Puppet Enterprise, published on 6 Aug 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lib/puppet/network/authstore.rb in Puppet before 2.7.18, and Puppet Enterprise before 2.5.2, supports use of IP addresses in certnames without warning of potential risks, which might allow remote attackers to spoof an agent by acquiring a previously used IP address.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2012-3408?

2 open source packages ship an affected version, including puppet. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puppet` | RubyGems | All versions | 2.7.18 |
| `puppet` | RubyGems | All versions | 2.7.18 |

Products: Puppet Puppet Enterprise, Puppetlabs Puppet.

## How do I fix CVE-2012-3408?

Upgrade puppet to 2.7.18 or later.

## Is CVE-2012-3408 being exploited?

There is no known exploitation of CVE-2012-3408 in the wild and no public exploit code.

## Other vulnerabilities in Puppet Puppet Enterprise

- [CVE-2023-2530](https://insights.sbomify.com/CVE-2023-2530/): Privilege escalation in Puppet Enterprise (critical 9.8)
- [CVE-2019-10694](https://insights.sbomify.com/CVE-2019-10694/): Hardcoded credentials in Puppet Enterprise (critical 9.8)
- [CVE-2018-11749](https://insights.sbomify.com/CVE-2018-11749/): Information disclosure in Puppet Enterprise (critical 9.8)
- [CVE-2021-27020](https://insights.sbomify.com/CVE-2021-27020/): Other in Puppet Enterprise (high 8.8)
- [CVE-2015-5686](https://insights.sbomify.com/CVE-2015-5686/): Cross-site request forgery in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-3408 and fix it if it is affected.

What it is: CVE-2012-3408 is a low-severity authentication bypass vulnerability in Puppet Puppet Enterprise, published on 6 Aug 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-3408 in the wild and no public exploit code.

Affected packages and fixed versions:
- puppet (RubyGems): affected all versions; fixed in 2.7.18
- puppet (RubyGems): affected all versions; fixed in 2.7.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-3408/ (Markdown: https://insights.sbomify.com/CVE-2012-3408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-3408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-3408
- OSV: https://osv.dev/vulnerability/CVE-2012-3408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-3408/
Summaries are generated and may contain mistakes; the official description above is the record.
