# CVE-2012-3424: actionpack Improper Authentication vulnerability

> Remote attackers can cause denial of service in Ruby on Rails applications using Digest Authentication by sending crafted credentials.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Aug 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-92w9-2pqw-rhjj

## What is CVE-2012-3424?

CVE-2012-3424 is a medium-severity denial of service vulnerability in Rubyonrails Rails, published on 8 Aug 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The decode_credentials method in actionpack/lib/action_controller/metal/http_authentication.rb in Ruby on Rails 3.x before 3.0.16, 3.1.x before 3.1.7, and 3.2.x before 3.2.7 converts Digest Authentication strings to symbols, which allows remote attackers to cause a denial of service by leveraging access to an application that uses a with_http_digest helper method, as demonstrated by the authenticate_or_request_with_http_digest method.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2012-3424?

8 open source packages ship an affected version, including actionpack. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | All versions | 2.3.5 |
| `actionpack` | RubyGems | All versions | 2.3.5 |
| `actionpack` | RubyGems | From 3.0.0.beta | 3.0.16 |
| `actionpack` | RubyGems | From 3.0.0.beta | 3.0.16 |
| `actionpack` | RubyGems | From 3.1.0 | 3.1.7 |
| `actionpack` | RubyGems | From 3.1.0 | 3.1.7 |
| `actionpack` | RubyGems | From 3.2.0 | 3.2.7 |
| `actionpack` | RubyGems | From 3.2.0 | 3.2.7 |

Products: Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2012-3424?

Upgrade actionpack to a fixed version for your release line: 2.3.5, 3.0.16, 3.1.7 or 3.2.7.

## Is CVE-2012-3424 being exploited?

There is no known exploitation of CVE-2012-3424 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-3424 and fix it if it is affected.

What it is: CVE-2012-3424 is a medium-severity denial of service vulnerability in Rubyonrails Rails, published on 8 Aug 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-3424 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected all versions; fixed in 2.3.5
- actionpack (RubyGems): affected all versions; fixed in 2.3.5
- actionpack (RubyGems): affected from 3.0.0.beta; fixed in 3.0.16
- actionpack (RubyGems): affected from 3.0.0.beta; fixed in 3.0.16
- actionpack (RubyGems): affected from 3.1.0; fixed in 3.1.7
- actionpack (RubyGems): affected from 3.1.0; fixed in 3.1.7
- actionpack (RubyGems): affected from 3.2.0; fixed in 3.2.7
- actionpack (RubyGems): affected from 3.2.0; fixed in 3.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-3424/ (Markdown: https://insights.sbomify.com/CVE-2012-3424/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-3424
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-3424
- OSV: https://osv.dev/vulnerability/CVE-2012-3424

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-3424/
Summaries are generated and may contain mistakes; the official description above is the record.
