# CVE-2012-3446: Apache Libcloud vulnerable to certificate impersonation

> Man-in-the-middle attackers can spoof SSL servers due to incorrect hostname verification in Apache Libcloud, bypassing certificate validation.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Nov 2012
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-3446, GHSA-prcq-52f8-fp44, PYSEC-2012-12

## What is CVE-2012-3446?

CVE-2012-3446 is a medium-severity vulnerability in n/a, published on 4 Nov 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Libcloud before 0.11.1 uses an incorrect regular expression during verification of whether the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via a crafted certificate.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2012-3446?

3 open source packages ship an affected version, including apache-libcloud. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-libcloud` | PyPI | All versions | 0.11.1 |
| `apache-libcloud` | PyPI | All versions | 0.11.1 |
| `apache-libcloud` | PyPI | All versions | 0.11.1 |

Products: Apache Libcloud.

## How do I fix CVE-2012-3446?

Upgrade apache-libcloud to 0.11.1 or later.

## Is CVE-2012-3446 being exploited?

There is no known exploitation of CVE-2012-3446 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2010-4340](https://insights.sbomify.com/CVE-2010-4340/): Apache Libcloud does not verify SSL certificates for HTTPS connections (medium 4.3)
- [CVE-2013-6480](https://insights.sbomify.com/CVE-2013-6480/): Libcloud does not properly scrub data when destroying a DigitalOcean node (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-3446 and fix it if it is affected.

What it is: CVE-2012-3446 is a medium-severity vulnerability in n/a, published on 4 Nov 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-3446 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-libcloud (PyPI): affected all versions; fixed in 0.11.1
- apache-libcloud (PyPI): affected all versions; fixed in 0.11.1
- apache-libcloud (PyPI): affected all versions; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-3446/ (Markdown: https://insights.sbomify.com/CVE-2012-3446/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-3446
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-3446
- OSV: https://osv.dev/vulnerability/CVE-2012-3446

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-3446/
Summaries are generated and may contain mistakes; the official description above is the record.
