{"answers":{"affected":"3 open source packages ship an affected version, including beaker. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-3458 in the wild and no public exploit code.","fix":"Upgrade beaker to a fixed version for your release line: 1.6.4 or 1.6.5.post1.","what":"CVE-2012-3458 is a medium-severity vulnerability in n/a, published on 15 Sep 2012. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-3458 and fix it if it is affected.\n\nWhat it is: CVE-2012-3458 is a medium-severity vulnerability in n/a, published on 15 Sep 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-3458 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- beaker (PyPI): affected all versions; fixed in 1.6.4\n- beaker (PyPI): affected all versions; fixed in 1.6.4\n- beaker (PyPI): affected all versions; fixed in 1.6.5.post1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-3458/ (Markdown: https://insights.sbomify.com/CVE-2012-3458/index.md)","id":"CVE-2012-3458","markdown":"https://insights.sbomify.com/CVE-2012-3458/index.md","name":"CVE-2012-3458","record":{"aliases":["DEBIAN-CVE-2012-3458","DSA-2541-1","GHSA-39vm-p9mr-4r27","PYSEC-2012-1","openSUSE-SU-2024:10317-1","openSUSE-SU-2024:11203-1","openSUSE-SU-2024:13886-1","openSUSE-SU-2026:11987-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Python web framework","requires_auth":"none","summary":"Remote attackers can obtain sensitive session data due to weak AES-ECB encryption in Beaker when PyCrypto is used.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"beaker","vendor":"python"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-310","name":null}],"description":"Beaker before 1.6.4, when using PyCrypto to encrypt sessions, uses AES in ECB cipher mode, which might allow remote attackers to obtain portions of sensitive session data via unspecified vectors.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Beaker Sensitive Information Disclosure vulnerability","id":"CVE-2012-3458","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2012"},"n_packages":5,"n_references":6,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2012-3459"},"packages":[{"ecosystem":"PyPI","fixed":["1.6.4"],"introduced":["0"],"last_affected":[],"package":"beaker","purl":null,"source":"GHSA-39vm-p9mr-4r27"},{"ecosystem":"PyPI","fixed":["1.6.4"],"introduced":["0"],"last_affected":[],"package":"beaker","purl":"pkg:pypi/beaker","source":"GHSA-39vm-p9mr-4r27"},{"ecosystem":"PyPI","fixed":["1.6.5.post1"],"introduced":["0"],"last_affected":[],"package":"beaker","purl":"pkg:pypi/beaker","source":"PYSEC-2012-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.11.0-5.5"],"introduced":["0"],"last_affected":[],"package":"python-Beaker","purl":"pkg:rpm/opensuse/python-Beaker\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11203-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.13.0-2.4"],"introduced":["0"],"last_affected":[],"package":"python-Beaker","purl":"pkg:rpm/opensuse/python-Beaker\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11987-1"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2012-3457"},"products":["n/a"],"published":"2012-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can obtain sensitive session data due to weak AES-ECB encryption in Beaker when PyCrypto is used.","url":"https://insights.sbomify.com/CVE-2012-3458/"}