CVE-2012-3464 activesupport Cross-site Scripting vulnerability

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML via quote characters in Ruby on Rails, potentially leading to session hijacking or data theft.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2012-3464?

CVE-2012-3464 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 10 Aug 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 might allow remote attackers to inject arbitrary web script or HTML via vectors involving a ' (quote) character.

Weakness: CWE-79

Which versions are affected by CVE-2012-3464?

8 open source packages ship an affected version, including activesupport. It affects 2 products.

PackageAffectedFixed in
activesupport RubyGemsAll versions2.3.16
activesupport RubyGemsAll versions2.3.16
activesupport RubyGemsFrom 3.0.0.beta3.0.17
activesupport RubyGemsFrom 3.0.0.beta3.0.17
activesupport RubyGemsFrom 3.1.03.1.8
activesupport RubyGemsFrom 3.1.03.1.8
2 more packages
activesupport RubyGemsFrom 3.2.03.2.8
activesupport RubyGemsFrom 3.2.03.2.8

Products include Rubyonrails Rails, Rubyonrails Ruby on Rails.

How do I fix CVE-2012-3464?

Upgrade activesupport to a fixed version for your release line: 2.3.16, 3.0.17, 3.1.8 or 3.2.8.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2012-3464 being exploited?

There is no known exploitation of CVE-2012-3464 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as DEBIAN-CVE-2012-3464, GHSA-h835-75hw-pj89.

Is CVE-2012-3464 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free