{"answers":{"affected":"8 open source packages ship an affected version, including activesupport. It affects 2 products.","exploited":"There is no known exploitation of CVE-2012-3464 in the wild and no public exploit code.","fix":"Upgrade activesupport to a fixed version for your release line: 2.3.16, 3.0.17, 3.1.8 or 3.2.8.","what":"CVE-2012-3464 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 10 Aug 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2012-3464 and fix it if it is affected.\n\nWhat it is: CVE-2012-3464 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 10 Aug 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2012-3464 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- activesupport (RubyGems): affected all versions; fixed in 2.3.16\n- activesupport (RubyGems): affected all versions; fixed in 2.3.16\n- activesupport (RubyGems): affected from 3.0.0.beta; fixed in 3.0.17\n- activesupport (RubyGems): affected from 3.0.0.beta; fixed in 3.0.17\n- activesupport (RubyGems): affected from 3.1.0; fixed in 3.1.8\n- activesupport (RubyGems): affected from 3.1.0; fixed in 3.1.8\n- activesupport (RubyGems): affected from 3.2.0; fixed in 3.2.8\n- activesupport (RubyGems): affected from 3.2.0; fixed in 3.2.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-3464/ (Markdown: https://insights.sbomify.com/CVE-2012-3464/index.md)","id":"CVE-2012-3464","markdown":"https://insights.sbomify.com/CVE-2012-3464/index.md","name":"CVE-2012-3464","record":{"aliases":["DEBIAN-CVE-2012-3464","GHSA-h835-75hw-pj89"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via quote characters in Ruby on Rails, potentially leading to session hijacking or data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"rails","vendor":"rubyonrails"},{"product":"ruby_on_rails","vendor":"rubyonrails"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 might allow remote attackers to inject arbitrary web script or HTML via vectors involving a ' (quote) character.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"activesupport Cross-site Scripting vulnerability","id":"CVE-2012-3464","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"rubyonrails:rails","products":["rubyonrails:rails"],"type":"xss","year":"2012"},"n_packages":8,"n_references":4,"next":{"headline":"actionpack Cross-site Scripting vulnerability","id":"CVE-2012-3465"},"packages":[{"ecosystem":"RubyGems","fixed":["2.3.16"],"introduced":["0"],"last_affected":[],"package":"activesupport","purl":null,"source":"GHSA-h835-75hw-pj89"},{"ecosystem":"RubyGems","fixed":["2.3.16"],"introduced":["0"],"last_affected":[],"package":"activesupport","purl":"pkg:gem/activesupport","source":"GHSA-h835-75hw-pj89"},{"ecosystem":"RubyGems","fixed":["3.0.17"],"introduced":["3.0.0.beta"],"last_affected":[],"package":"activesupport","purl":null,"source":"GHSA-h835-75hw-pj89"},{"ecosystem":"RubyGems","fixed":["3.0.17"],"introduced":["3.0.0.beta"],"last_affected":[],"package":"activesupport","purl":"pkg:gem/activesupport","source":"GHSA-h835-75hw-pj89"},{"ecosystem":"RubyGems","fixed":["3.1.8"],"introduced":["3.1.0"],"last_affected":[],"package":"activesupport","purl":null,"source":"GHSA-h835-75hw-pj89"},{"ecosystem":"RubyGems","fixed":["3.1.8"],"introduced":["3.1.0"],"last_affected":[],"package":"activesupport","purl":"pkg:gem/activesupport","source":"GHSA-h835-75hw-pj89"},{"ecosystem":"RubyGems","fixed":["3.2.8"],"introduced":["3.2.0"],"last_affected":[],"package":"activesupport","purl":null,"source":"GHSA-h835-75hw-pj89"},{"ecosystem":"RubyGems","fixed":["3.2.8"],"introduced":["3.2.0"],"last_affected":[],"package":"activesupport","purl":"pkg:gem/activesupport","source":"GHSA-h835-75hw-pj89"}],"prev":{"headline":"actionpack Cross-site Scripting vulnerability","id":"CVE-2012-3463"},"products":["n/a"],"published":"2012-08-10","related":[{"cvss_score":10,"headline":"Active Record contains deserialization of arbitrary YAML","id":"CVE-2013-0277","kev_date_added":null,"published":"2013-02-13"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17916","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17917","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8,"headline":"Rails Active Storage has possible Path Traversal in DiskService","id":"CVE-2026-33195","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":7.5,"headline":"Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch","id":"CVE-2024-26142","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":7.5,"headline":"ReDoS based DoS vulnerability in Action Dispatch","id":"CVE-2023-22792","kev_date_added":null,"published":"2023-02-09"},{"cvss_score":7.5,"headline":"Denial of Service in Action Dispatch","id":"CVE-2021-22902","kev_date_added":null,"published":"2021-06-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via quote characters in Ruby on Rails, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2012-3464/"}