# CVE-2012-3467: Apache QPID Allows Remote Authentication Bypass

> Remote attackers can bypass authentication for catch-up shadow connections in Apache QPID AMQP brokers due to a NullAuthenticator mechanism.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2012
- **Updated:** 6 Aug 2024
- **Also known as:** CVE-2012-3550, GHSA-phw8-fw9g-v3xc, RHSA-2012:1279

## What is CVE-2012-3467?

CVE-2012-3467 is a medium-severity authentication bypass vulnerability in n/a, published on 27 Aug 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache QPID 0.14, 0.16, and earlier uses a NullAuthenticator mechanism to authenticate catch-up shadow connections to AMQP brokers, which allows remote attackers to bypass authentication.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2012-3467?

2 open source packages ship an affected version, including org.apache.qpid:qpid-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.qpid:qpid-parent` | Maven | All versions | 0.17 |
| `org.apache.qpid:qpid-parent` | Maven | All versions | 0.17 |
| `mrg-release` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:2.2.0-1.el6 |
| `python-qpid-qmf` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.14-14.el6_3 |
| `qpid-cpp` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-client` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-client-ssl` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-debuginfo` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-server` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-server-ssl` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-qmf` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.14-14.el6_3 |
| `qpid-qmf-debuginfo` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.14-14.el6_3 |
| `ruby-qpid-qmf` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:0.14-14.el6_3 |
| `xerces-c` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:3.0.1-20.el6 |
| `xerces-c-debuginfo` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:3.0.1-20.el6 |
| `xerces-c-devel` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:3.0.1-20.el6 |
| `xerces-c-doc` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:3.0.1-20.el6 |
| `xqilla` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:2.2.3-8.el6 |
| `xqilla-debuginfo` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:2.2.3-8.el6 |
| `xqilla-devel` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:2.2.3-8.el6 |
| `xqilla-doc` | Red Hat:enterprise_mrg:2:computenode:el6 | All versions | 0:2.2.3-8.el6 |
| `mrg-release` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:2.2.0-1.el6 |
| `python-qpid-qmf` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-14.el6_3 |
| `qpid-cpp` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-client` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-client-devel` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-client-devel-docs` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-client-rdma` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-client-ssl` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-debuginfo` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-server` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-server-cluster` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-server-devel` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-server-rdma` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-server-ssl` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-server-store` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-cpp-server-xml` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.14-22.el6_3 |
| `qpid-java` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-2.el6 |
| `qpid-java-client` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-2.el6 |
| `qpid-java-common` | Red Hat:enterprise_mrg:2:server:el6 | All versions | 0:0.18-2.el6 |

Products: Apache Qpid.

## How do I fix CVE-2012-3467?

Upgrade org.apache.qpid:qpid-parent to 0.17 or later.

## Is CVE-2012-3467 being exploited?

There is no known exploitation of CVE-2012-3467 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-0224](https://insights.sbomify.com/CVE-2015-0224/): Denial of service in n/a (high 7.5)
- [CVE-2011-3620](https://insights.sbomify.com/CVE-2011-3620/): Auth bypass in n/a (high 7.5)
- [CVE-2019-0223](https://insights.sbomify.com/CVE-2019-0223/): Security feature bypass in Apache Qpid Proton (high 7.4)
- [CVE-2012-4446](https://insights.sbomify.com/CVE-2012-4446/): Improper Authentication in Apache Qpid (medium 6.8)
- [CVE-2015-0203](https://insights.sbomify.com/CVE-2015-0203/): Denial of service in n/a (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-3467 and fix it if it is affected.

What it is: CVE-2012-3467 is a medium-severity authentication bypass vulnerability in n/a, published on 27 Aug 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-3467 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.qpid:qpid-parent (Maven): affected all versions; fixed in 0.17
- org.apache.qpid:qpid-parent (Maven): affected all versions; fixed in 0.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-3467/ (Markdown: https://insights.sbomify.com/CVE-2012-3467/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-3467
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-3467
- OSV: https://osv.dev/vulnerability/CVE-2012-3467

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-3467/
Summaries are generated and may contain mistakes; the official description above is the record.
