# CVE-2012-3503: Katello uses hard coded credential

> Remote attackers can authenticate as arbitrary users in Katello CloudForms by exploiting a default secret token generated during installation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-5xv2-q475-rwrh

## What is CVE-2012-3503?

CVE-2012-3503 is a critical vulnerability in Redhat Enterprise Linux Server, published on 25 Aug 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The installation script in Katello 1.0 and earlier does not properly generate the Application.config.secret_token value, which causes each default installation to have the same secret token, and allows remote attackers to authenticate to the CloudForms System Engine web interface as an arbitrary user by creating a cookie using the default secret_token.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2012-3503?

4 open source packages ship an affected version, including katello. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `katello` | RubyGems | All versions | 1.0.6 |
| `katello` | RubyGems | All versions | 1.0.6 |
| `katello` | RubyGems | From 1.1.0 | 1.1.7 |
| `katello` | RubyGems | From 1.1.0 | 1.1.7 |

Products: Redhat Enterprise Linux Server, Theforeman Katello.

## How do I fix CVE-2012-3503?

Upgrade katello to a fixed version for your release line: 1.0.6 or 1.1.7.

## Is CVE-2012-3503 being exploited?

There is no known exploitation of CVE-2012-3503 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Enterprise Linux Server

- [CVE-2014-0130](https://insights.sbomify.com/CVE-2014-0130/): Ruby on Rails Directory Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-3503 and fix it if it is affected.

What it is: CVE-2012-3503 is a critical vulnerability in Redhat Enterprise Linux Server, published on 25 Aug 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-3503 in the wild and no public exploit code.

Affected packages and fixed versions:
- katello (RubyGems): affected all versions; fixed in 1.0.6
- katello (RubyGems): affected all versions; fixed in 1.0.6
- katello (RubyGems): affected from 1.1.0; fixed in 1.1.7
- katello (RubyGems): affected from 1.1.0; fixed in 1.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-3503/ (Markdown: https://insights.sbomify.com/CVE-2012-3503/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-3503
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-3503
- OSV: https://osv.dev/vulnerability/CVE-2012-3503

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-3503/
Summaries are generated and may contain mistakes; the official description above is the record.
